summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 17:17:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 17:18:39 +0100
commitd1b41b2c5b14eb4e136599d2f65159c62501573c (patch)
tree4ec6d91563715d673b4ab2b2115c69fe5c3b162e /dev-python/mysql-connector-python
parentdev-python/nest_asyncio: Remove old (diff)
downloadgentoo-d1b41b2c5b14eb4e136599d2f65159c62501573c.tar.gz
gentoo-d1b41b2c5b14eb4e136599d2f65159c62501573c.tar.bz2
gentoo-d1b41b2c5b14eb4e136599d2f65159c62501573c.zip
dev-python/mysql-connector-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index a3e75715ec06..9a84033b5b95 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,2 +1 @@
-DIST mysql-connector-python-8.0.21.tar.gz 12069002 BLAKE2B db4e7672f0daace08c88e52560db66629d5eb9d9903b76e616bed7ef4a21d80139a65ac24d47d16f9fa5e978f3acb262292c72933f0c348d9494cd51f96f1654 SHA512 d73efd99774450bbf729ddbb19b80d09b8db151715d12b76e40497bf1d9ff658e0ad1e22dc9a73dd5f6736f7c075f94808a2f28b1c975aaa380bbb92cf4e7184
DIST mysql-connector-python-8.0.22.tar.gz 12081967 BLAKE2B fc6b724ec2eb47a92294f7316093d4a4d2f4925981adeb07b305e946a047dbdaedd96c6ff9a07426fd56185f467cf6473bc84e0896d2e8fde70a188af16e9df2 SHA512 07f380922c18f9ade38f95d8e107fe8f90b8a7901fb9a36bbdfdb2b29f9cb79b0b6387a608e89bf90e9344c635d47184c750a206beacb2c9cc7615d6a7df2c29
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
deleted file mode 100644
index ae8e4244143f..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="amd64 arm x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-BDEPEND=">=dev-libs/protobuf-3.6.1"
-
-RDEPEND="
- >=dev-db/mysql-connector-c-8.0
- >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
-"
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt README.rst )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-# Yeah, this is really broken, but the extension will only build this way during "install"
-python_install() {
- distutils-r1_python_install \
- --with-mysql-capi="${EPREFIX}/usr" \
- --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
- --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --with-protoc="${EPREFIX}/usr/bin/protoc"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}