summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-20 23:16:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-20 23:33:20 +0200
commit871c5ccbeb449fdcb7d9065e5af94de60b274455 (patch)
treef724a1029d0a6efc60c9dd0d606eed9680c86992 /dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild
parentprofiles/package.mask: remove x11-terms/aterm from the chopping block (diff)
downloadgentoo-871c5ccbeb449fdcb7d9065e5af94de60b274455.tar.gz
gentoo-871c5ccbeb449fdcb7d9065e5af94de60b274455.tar.bz2
gentoo-871c5ccbeb449fdcb7d9065e5af94de60b274455.zip
dev-python/nagiosplugin: support Python 3.8, use distutils_* helpers
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild')
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..fba554d9f858
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="ZPL"
+SLOT="0"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme