summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-11-10 03:29:40 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-11-10 03:30:24 +0100
commit374219a355ba4ab7cebdb367bab2bf0ad83d5bf3 (patch)
treebd19d4432d63e3862245447177e1ea5a7751f6b7 /dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
parentnet-mail/altermime: bump EAPI and stuff (diff)
downloadgentoo-374219a355ba4ab7cebdb367bab2bf0ad83d5bf3.tar.gz
gentoo-374219a355ba4ab7cebdb367bab2bf0ad83d5bf3.tar.bz2
gentoo-374219a355ba4ab7cebdb367bab2bf0ad83d5bf3.zip
dev-python/nagiosplugin: bump to 1.3.2, tests are back on PyPI
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild')
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
new file mode 100644
index 000000000000..cd0ca3c9a35e
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+LICENSE="ZPL"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc doc/_build/html || die
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vv tests || die "tests failed with ${EPYTHON}"
+}