summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-01-02 12:04:12 +0100
committerJustin Lecher <jlec@gentoo.org>2017-01-02 22:09:25 +0000
commitf9daab8b0dff06d345f733e8d5550c7d3853b1c8 (patch)
treeee2fa1cb3629fbbdfbdeab9b4816a84e374dd91e /dev-python/nbdime
parentdev-util/nvidia-cuda-toolkit: Drop old (diff)
downloadgentoo-f9daab8b0dff06d345f733e8d5550c7d3853b1c8.tar.gz
gentoo-f9daab8b0dff06d345f733e8d5550c7d3853b1c8.tar.bz2
gentoo-f9daab8b0dff06d345f733e8d5550c7d3853b1c8.zip
dev-python/nbdime: New package.
nbdime provides tools for diffing and merging of Jupyter Notebooks. Beside console based diffing and merging tools, web-based diffing and merging tools are provided (requiring npm). The ebuild is based on the live ebuild in the science overlay, https://github.com/gentoo-science/sci, which was added by me to the overlay. Gentoo-Bug: https://bugs.gentoo.org/604372 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3301
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/metadata.xml24
-rw-r--r--dev-python/nbdime/nbdime-0.1.0.ebuild55
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
new file mode 100644
index 000000000000..40dcd99234c4
--- /dev/null
+++ b/dev-python/nbdime/Manifest
@@ -0,0 +1 @@
+DIST nbdime-0.1.0.tar.gz 3849944 SHA256 5af53ccf5b265546e61fbc096c4dd8122855b2aa02f8b60a99eeee01a8e33043 SHA512 e110e2e3e8b9bfbaafd26e6558ec863eb0a23f3b7a67482e497c4883fa2151ae058582b975aca90392bd2314f5e32ce3e7316db9c2c37e44c336a9fcf88176c8 WHIRLPOOL 074060d867b259b461514e84b21c0f7eb20ff2f787055e03971fd18d0aa1ba56596b15017354c5becd3f1022b5557ec740d4815d4f820af8b54349273ee8b9a4
diff --git a/dev-python/nbdime/metadata.xml b/dev-python/nbdime/metadata.xml
new file mode 100644
index 000000000000..b2a229dc3754
--- /dev/null
+++ b/dev-python/nbdime/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ nbdime provides tools for diffing and merging of Jupyter Notebooks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/nbdime</remote-id>
+ <remote-id type="pypi">nbdime</remote-id>
+ </upstream>
+ <use>
+ <flag name="webtools">
+ Install web-based diff and merge tools.
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/dev-python/nbdime/nbdime-0.1.0.ebuild b/dev-python/nbdime/nbdime-0.1.0.ebuild
new file mode 100644
index 000000000000..718527d03392
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}