summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-25 18:57:08 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:25:48 +0000
commit3010ddb6d75696ba494d5180aabd65e8b19810a0 (patch)
treed9090b0bba7cdeb65d3ccd4b851c492a04e28165 /dev-python/nbval
parentdev-python/pytzdata: Mark ALLARCHES (diff)
downloadgentoo-3010ddb6d75696ba494d5180aabd65e8b19810a0.tar.gz
gentoo-3010ddb6d75696ba494d5180aabd65e8b19810a0.tar.bz2
gentoo-3010ddb6d75696ba494d5180aabd65e8b19810a0.zip
dev-python/nbval: Bump to 0.9.6
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/nbval')
-rw-r--r--dev-python/nbval/Manifest1
-rw-r--r--dev-python/nbval/nbval-0.9.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/nbval/Manifest b/dev-python/nbval/Manifest
index 76658bda7211..d05642d0a647 100644
--- a/dev-python/nbval/Manifest
+++ b/dev-python/nbval/Manifest
@@ -1 +1,2 @@
DIST nbval-0.9.1.tar.gz 64476 BLAKE2B 299f6cb9a1e28b80b2e27a74f2b6614e83e5b571b1dc27d0f6829693dd0f6c2b59845543c91487615a8621e21ac2cbc2d34e60e62b7a646914283e23649d8bd9 SHA512 8ab0cb4e09907d99f898b148b635f0818660d04417c1c809beb93680862a5ecab14b606ecc3f90eff85e5f01de7dbf10954f1edf3629a1cf8ddac00556d4d6e7
+DIST nbval-0.9.6.tar.gz 60932 BLAKE2B 77f283279e16e03ec87f250b2012aabd8f580e24b222efcb0b21d9b0dadc381cea3c4a3f96a85df0104da86911de66e6c21bfd3985801fa9c3d8764b2fb26183 SHA512 d4261fc30e197e7350c07504649f0230751b5ed746fe4626b92c5920032dc15abe47ad421c93f4762e93a8b6afcbca440ca006bfd1cdbcba37d131c4e6decaa7
diff --git a/dev-python/nbval/nbval-0.9.6.ebuild b/dev-python/nbval/nbval-0.9.6.ebuild
new file mode 100644
index 000000000000..dd0eb843e62f
--- /dev/null
+++ b/dev-python/nbval/nbval-0.9.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
+HOMEPAGE="https://github.com/computationalmodelling/nbval"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ --deselect tests/test_ignore.py::test_conf_ignore_stderr
+ --deselect tests/test_timeouts.py::test_timeouts
+ )
+
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}