summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-09 17:08:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-09 17:35:30 +0200
commite89cfe5e765986f34fa9da5c927cf9de04a96154 (patch)
tree7217d3e80f7dd902954612e9e2b0c89fa90c07de /dev-python/ndg-httpsclient
parentdev-python/zc-buildout: Fix namespace support (diff)
downloadgentoo-e89cfe5e765986f34fa9da5c927cf9de04a96154.tar.gz
gentoo-e89cfe5e765986f34fa9da5c927cf9de04a96154.tar.bz2
gentoo-e89cfe5e765986f34fa9da5c927cf9de04a96154.zip
dev-python/ndg-httpsclient: Fix namespace support
Diffstat (limited to 'dev-python/ndg-httpsclient')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..e7fb90d1d39b
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken
+
+python_install() {
+ distutils-r1_python_install
+
+ # install the namespace (this is the only package in ::gentoo
+ # using it; we'll split it if we add more)
+ python_moduleinto ndg
+ python_domodule ndg/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}