summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-11-28 11:57:57 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-28 12:07:27 -0800
commit28c71109140d3a4f166f3f1a32d0c032afaf23cb (patch)
treec008158a81f4fe14604027637c076989ca418459 /dev-python/neovim-python-client
parentdev-python/msgpack-0.6.2: version bump, add py38 and pypy3 (diff)
downloadgentoo-28c71109140d3a4f166f3f1a32d0c032afaf23cb.tar.gz
gentoo-28c71109140d3a4f166f3f1a32d0c032afaf23cb.tar.bz2
gentoo-28c71109140d3a4f166f3f1a32d0c032afaf23cb.zip
app-editors/neovim-0.4.3: Version bump, add py38, pypy{,3}
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/neovim-python-client')
-rw-r--r--dev-python/neovim-python-client/Manifest1
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/Manifest b/dev-python/neovim-python-client/Manifest
index 16d006019fec..bf5ade42e37c 100644
--- a/dev-python/neovim-python-client/Manifest
+++ b/dev-python/neovim-python-client/Manifest
@@ -1,2 +1,3 @@
DIST neovim-python-client-0.3.1.tar.gz 51626 BLAKE2B 80e68d02d41c7891fb88e9386866f87a1c78acc9e279de4ce4c7022333f8da3b68ffe7c598c84ff9c6386458639b6ffb4aecbfe72288866dc147ffc6197e94e2 SHA512 9c1599aabce9f0e1133364f8e91dd1b57cee107a11d400f530218ec7ad157c2f58134c1e7e8fc27649b4d8953e27c51bf6e4f0e7565d8c3dab94788759eea229
DIST neovim-python-client-0.3.2.tar.gz 51954 BLAKE2B 8e0a5eb510797db260ab501b751921f5c98551a06cf874eecff270f5f92da5d24539b857b4cc08494be9dfed139fd3bcab1cdea75ee87d99cece8e1f48f7a1c5 SHA512 c6d7c1a2955c63ac2f59bc57e190886fe0ee0238951ac26205b537d394b2ce2fee3611e8651ae1da5e6e7b3a1bd3bea36912b918b26e01bbb3354ddc2fbd77fc
+DIST neovim-python-client-0.4.0.tar.gz 53443 BLAKE2B de37fde43e90e8277f3c69cedde9226e929f122cc2ff3030766fa716069114bffb27ea9489f2de87c69d3e7a8e0ecc22397a94168cee542d37dc827dc3ed3d13 SHA512 4b3b0e295181cf8886850477d01daba1cba8ac456aedadc5b3881b0b4910724450c4e7774282f6edf3e322792b697ae8e925f40b2a0b181a95eee48aef42a97a
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.4.0.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.4.0.ebuild
new file mode 100644
index 000000000000..66bdce84077c
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/pynvim-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+ ${DEPEND}
+ app-editors/neovim"
+
+distutils_enable_tests pytest
+
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -r -i "/^msgpack/d ; s:[\"']pytest-runner[\"'](,|)::" setup.py || die
+ distutils-r1_python_prepare_all
+}