summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2019-10-05 17:19:52 -0400
committerJoonas Niilola <juippis@gentoo.org>2019-10-09 08:21:26 +0300
commit14eb6706a5a099c77bbabd0814f3dd50f4970f0f (patch)
tree391c59265c175301b0aeb49b2fd4390527439757 /dev-python/neovim-remote
parentapp-crypt/acme-sh: update live ebuild (diff)
downloadgentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.tar.gz
gentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.tar.bz2
gentoo-14eb6706a5a099c77bbabd0814f3dd50f4970f0f.zip
dev-python/neovim-remote: version bump to 2.2.1
Closes: https://bugs.gentoo.org/696636 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/13177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
index 905bbdff8ac3..e5c1a7644a06 100644
--- a/dev-python/neovim-remote/Manifest
+++ b/dev-python/neovim-remote/Manifest
@@ -1,3 +1,4 @@
DIST neovim-remote-1.8.6.tar.gz 434012 BLAKE2B 1fddb5e4376d3d17c2ff0c00e5f98700ab2d221af1ed1bc3f9c6dabe9cf1bdafe9f85041cb3a01f9a45f03df2d76bc0ae3c5a93603caa9ad461eb5ae50cb832f SHA512 b973b8c495a3a371b9a21ec4110beebbfe304f00d73aaf1da849df612e6ea9a08258379600ccb8d83154b8ef12e26088ba90a1668c5262b7dc9c62c844f42798
DIST neovim-remote-2.1.0.tar.gz 437657 BLAKE2B 056bcc1edff5225b478e72f0b0ce3b8f296ed49d9d8a035bce88b6d26daeda884640f9f6a50b68d91a8ad38a4980f554385e799302a541ce2d6985110357188d SHA512 23f6e98d57d856477b51c77aaa417af8a7a9aa02821f4dbd4870af7b3f9de07c4ba46ceae036ddb17382de4829238114dafa4b2b6d1e6dc71f1d9b4ba935b562
DIST neovim-remote-2.1.7.tar.gz 438133 BLAKE2B 37bcbabbc4336f31ddb20aae27c748fef80924d095ef285a27105b8276a89dd681a9ea210a4b1286cf7ae5461364044fa97889b803c0de15d18df09e0ad78e2f SHA512 544c2b60b751cd72da793f1ea69fb0fed8990f009320ce6972cdb17af5ae2cc526af85bdc57f03a85cee1b8e3fdcd357a99a91252e44ae0761d3772f1714c240
+DIST neovim-remote-2.2.1.tar.gz 438078 BLAKE2B abbb056a10acb1c4e21c0c418ee2d6003869340eb34df0c0374b947fbbfa2d2e0f64f61ad571a6cad7ffad7374f1df17a519795e61b37b8d6741d566760759e9 SHA512 04a16a1ed5f4947b4fd763432a14fc565300abe9b480037a462f0c4700535d4854012ff08ac64234dbb1fccc1d3f5ba2174f94effc5564879fbcd1c83fee26ae
diff --git a/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild b/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild
new file mode 100644
index 000000000000..c07980e22fc2
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die
+}