summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-05 10:52:33 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-05 14:25:39 +0100
commit1f4739e6d1dcf93449abaf8d74227fea4293e742 (patch)
treee732e4cb2c26b5f1ef517caa489d2694fcf2c292 /dev-python/networkx
parentapp-i18n/ibus: amd64 stable wrt bug #641276 (diff)
downloadgentoo-1f4739e6d1dcf93449abaf8d74227fea4293e742.tar.gz
gentoo-1f4739e6d1dcf93449abaf8d74227fea4293e742.tar.bz2
gentoo-1f4739e6d1dcf93449abaf8d74227fea4293e742.zip
dev-python/networkx: Clean old up
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-1.10-r1.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index f8854b510a38..99fb7c47f746 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,2 +1 @@
-DIST networkx-1.10.tar.gz 1189291 BLAKE2B 784dde9b5a0c1a1ee8f88aa00b6c89679df8d078d7706d28b5a1d0633144dd9866345a6f1818660d8ca343b4a3ab6597bc18f8881868763c79346cd8d95fd9c0 SHA512 fc0a0b929991baef63c30382c2045d551b217140393a4264b18a5f1be198d325eee9f57e02dda38a7ad9f99771c5b78f82c673a88b04df122b9d91852db09efd
DIST networkx-1.11.tar.gz 1315737 BLAKE2B 9f6556af1a4e23bf7fcf51fcbc753a08f2616dfe63c7b05fbe20ad7532580bf566c44ddc5db0c0d89626a17fd2029485583b513f44688e8033ca83cb36f28315 SHA512 622c93330bb5ba93a2be087f7f19963a1bb9a50dc72b6500ea8321c36aa9da19af379c5cd4bbee8bba3cb6e68a28f11ee24bbe333047f5c7d0ce0b755fd57253
diff --git a/dev-python/networkx/networkx-1.10-r1.ebuild b/dev-python/networkx/networkx-1.10-r1.ebuild
deleted file mode 100644
index 4e2807d4e82f..000000000000
--- a/dev-python/networkx/networkx-1.10-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-COMMON_DEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/numpydoc[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]' python2_7 python{3_3,3_4})
- )
- test? (
- ${COMMON_DEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pydot[${PYTHON_USEDEP}]' python2_7)
- )"
-RDEPEND="
- >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
- examples? (
- ${COMMON_DEPEND}
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_prepare_all() {
- # Avoid d'loading of file objects.inv from 2 sites of python docs
- sed -e "s/'sphinx.ext.intersphinx', //" -i doc/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # https://github.com/networkx/networkx/issues/1263
- if use doc; then
- sed \
- -e "s:^\t\./:\t${PYTHON} :g" \
- -i doc/Makefile || die
- emake -C doc html
- fi
-}
-
-python_test() {
- nosetests -vv || die
-}
-
-python_install_all() {
- # Oh my.
- rm -r "${ED}"usr/share/doc/${P} || die
-
- use doc && local HTML_DOCS=( doc/build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}