summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-23 07:56:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-23 17:18:35 +0200
commitbb27e0565498e52ae578842e9b933155c649b0f3 (patch)
tree847ee5857b72d3a763cf912c6f98af5c30028fa5 /dev-python/networkx
parentdev-python/dask: Bump to 2.24.0 (diff)
downloadgentoo-bb27e0565498e52ae578842e9b933155c649b0f3.tar.gz
gentoo-bb27e0565498e52ae578842e9b933155c649b0f3.tar.bz2
gentoo-bb27e0565498e52ae578842e9b933155c649b0f3.zip
dev-python/networkx: Bump to 2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index a5e05b0f2ba5..35dd0c4f7f47 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
DIST networkx-2.4.tar.gz 1462338 BLAKE2B 90fd7d249f3b022dd9c861dd023881fd241cba0515e2e9991516c278a40b92ee03663eb2b15bd584f179c066529df0587293f9c9a211e7c526addf77fdaf5cd6 SHA512 38eabef56e3667b7fa85206ae01a0a8f5c71bfa2f324bc2490c433cb973508a03955183a0c58ae40390f86d6a4741135cdb426c4c15e53e2f123072f0cac1b89
+DIST networkx-2.5.tar.gz 1542085 BLAKE2B a4d1d1f65a09f8e7cd830a9e670cf540c19b800dffb90aa1cc6ebda8b6116b6181969382f90339254746a3f277d786020506a3c8f10c90ff48999d3b2c3c433e SHA512 ab51198072d20bdba7c9ceb6856631a20a7e9527a7cadb41271a999f57bf60da5488269c6e4e1f3f4f33420ec6493af665386842c216ea1cfadd1792ccb6444e
diff --git a/dev-python/networkx/networkx-2.5.ebuild b/dev-python/networkx/networkx-2.5.ebuild
new file mode 100644
index 000000000000..7b9a1d6f392f
--- /dev/null
+++ b/dev-python/networkx/networkx-2.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="https://networkx.github.io/ https://github.com/networkx/networkx"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples extras pandas scipy test xml yaml"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
+ extras? (
+ >=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
+ ' python3_{6,7,8})
+ )
+ pandas? (
+ >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}]
+ )
+ scipy? ( >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}] )
+ xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}