summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 22:57:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:51 -0500
commitf9325033dbaedf4008d12113c8c685c08e0fdaec (patch)
tree0d666d24e4928aefbc8e628417932f658f10960e /dev-python/networkx
parentdev-python/pandas: 0.24.1 add py37 support (diff)
downloadgentoo-f9325033dbaedf4008d12113c8c685c08e0fdaec.tar.gz
gentoo-f9325033dbaedf4008d12113c8c685c08e0fdaec.tar.bz2
gentoo-f9325033dbaedf4008d12113c8c685c08e0fdaec.zip
dev-python/networkx: 2.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index d0df01630f96..aaaa1fd2ea29 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,2 +1,3 @@
DIST networkx-1.11.tar.gz 1315737 BLAKE2B 9f6556af1a4e23bf7fcf51fcbc753a08f2616dfe63c7b05fbe20ad7532580bf566c44ddc5db0c0d89626a17fd2029485583b513f44688e8033ca83cb36f28315 SHA512 622c93330bb5ba93a2be087f7f19963a1bb9a50dc72b6500ea8321c36aa9da19af379c5cd4bbee8bba3cb6e68a28f11ee24bbe333047f5c7d0ce0b755fd57253
DIST networkx-2.1.zip 1612593 BLAKE2B 0a603617105bb1efa3711f81a468520eef5f56438bf6e730091a43b628d04fdd22e8b62de671dbe98be180bff68b3ea4af61e475fcc1f274537ccd1e74fcdff5 SHA512 61b819ccfdd38e009e5b363f4bf551f2924bbf751b078aab1b41da9faf4c6b0841f38750b96bd359d3aebefef01e65e88b4c43a378ec25bbd45283d92bdae678
+DIST networkx-2.2.zip 1700336 BLAKE2B 8cd4bda4100d5da10864f3b08d5a7faa11399176cfe39691aef46234a3de71bb175a3ac0b179cce9971c1954d0fc13469e41d610191c7827f1212d0e9ef1e3aa SHA512 098e58c5f93c72c789e736102815e2f6388eb34147a674941519ef6f6d6452cc09b76d8523893418cb69df133e7623ea2c62fa51144f598f592ebce0e3e3ccbb
diff --git a/dev-python/networkx/networkx-2.2.ebuild b/dev-python/networkx/networkx-2.2.ebuild
new file mode 100644
index 000000000000..8a0ae3aafc81
--- /dev/null
+++ b/dev-python/networkx/networkx-2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples extras pandas scipy test xml yaml"
+
+REQUIRED_USE="
+ test? ( extras pandas scipy xml yaml )"
+
+COMMON_DEPEND="
+ >=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
+ extras? (
+ >=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
+ )
+ pandas? ( >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}] )
+ scipy? ( >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}] )
+ xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ examples? (
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+)
+
+python_test() {
+ virtx nosetests -vv || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}