summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-12 11:36:25 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-13 10:41:36 +0100
commit3969fb3914f5bf6c2d569638cc6239ee2d3a48fb (patch)
tree723eb3a7b1fb0b4ef5fc55fe7dd760057e857f93 /dev-python/neutron-lib
parentdev-python/mox3: Remove Python 2 support (diff)
downloadgentoo-3969fb3914f5bf6c2d569638cc6239ee2d3a48fb.tar.gz
gentoo-3969fb3914f5bf6c2d569638cc6239ee2d3a48fb.tar.bz2
gentoo-3969fb3914f5bf6c2d569638cc6239ee2d3a48fb.zip
dev-python/neutron-lib: Remove Python 2 support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/neutron-lib')
-rw-r--r--dev-python/neutron-lib/neutron-lib-1.18.0.ebuild3
-rw-r--r--dev-python/neutron-lib/neutron-lib-1.25.0.ebuild3
-rw-r--r--dev-python/neutron-lib/neutron-lib-1.29.1.ebuild3
3 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/neutron-lib/neutron-lib-1.18.0.ebuild b/dev-python/neutron-lib/neutron-lib-1.18.0.ebuild
index 84c30d964607..0c00989638cc 100644
--- a/dev-python/neutron-lib/neutron-lib-1.18.0.ebuild
+++ b/dev-python/neutron-lib/neutron-lib-1.18.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -48,5 +48,4 @@ RDEPEND="${CDEPEND}
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]"
diff --git a/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild b/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
index d8512ce621b1..f6fac8a2e762 100644
--- a/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
+++ b/dev-python/neutron-lib/neutron-lib-1.25.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -45,6 +45,5 @@ RDEPEND="${CDEPEND}
>=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
>=dev-python/setproctitle-1.1.10[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/os-traits-0.9.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]"
diff --git a/dev-python/neutron-lib/neutron-lib-1.29.1.ebuild b/dev-python/neutron-lib/neutron-lib-1.29.1.ebuild
index 9d7cc685412a..ca6dda873e75 100644
--- a/dev-python/neutron-lib/neutron-lib-1.29.1.ebuild
+++ b/dev-python/neutron-lib/neutron-lib-1.29.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -47,6 +47,5 @@ RDEPEND="${CDEPEND}
>=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
>=dev-python/setproctitle-1.1.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/weakrefmethod-1.0.2[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/os-traits-0.9.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]"