summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 23:44:40 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 23:54:36 -0700
commiteb15c54fc15e30e0ef38796a7fefb3325b43ef74 (patch)
tree63e581a06ffa8d8f18ebb70e9c0061b5ab7d9cb4 /dev-python/nose-random
parentdev-python/aws-xray-sdk-python-2.4.2: add py38 (diff)
downloadgentoo-eb15c54fc15e30e0ef38796a7fefb3325b43ef74.tar.gz
gentoo-eb15c54fc15e30e0ef38796a7fefb3325b43ef74.tar.bz2
gentoo-eb15c54fc15e30e0ef38796a7fefb3325b43ef74.zip
dev-python/nose-random: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/nose-random')
-rw-r--r--dev-python/nose-random/Manifest1
-rw-r--r--dev-python/nose-random/metadata.xml11
-rw-r--r--dev-python/nose-random/nose-random-1.0.0.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/nose-random/Manifest b/dev-python/nose-random/Manifest
new file mode 100644
index 000000000000..2c54bf9c19dc
--- /dev/null
+++ b/dev-python/nose-random/Manifest
@@ -0,0 +1 @@
+DIST nose-random-1.0.0.tar.gz 3776 BLAKE2B 18dc40b13fcb970c4d2edeb6be9c6f3e710b36d14dcdc4a56c6e3ecf811ab2acd6be3e1c1cea2231eb5dc10581c77f201220354c77f3d9f67d89d894ed8b4f24 SHA512 9c62413fb00c3b774954ae7a65b08b122ae0dd2b24377efba8de345597b4ce4952aad09a0c2fea7f9d92f57a3664908fccd6eabadf32074a35978c958ea2b66f
diff --git a/dev-python/nose-random/metadata.xml b/dev-python/nose-random/metadata.xml
new file mode 100644
index 000000000000..2541628cf9a8
--- /dev/null
+++ b/dev-python/nose-random/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/nose-random/nose-random-1.0.0.ebuild b/dev-python/nose-random/nose-random-1.0.0.ebuild
new file mode 100644
index 000000000000..c4a593c95802
--- /dev/null
+++ b/dev-python/nose-random/nose-random-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to facilitate randomized unit testing"
+HOMEPAGE="https://github.com/fzumstein/nose-random"
+SRC_URI="https://github.com/fzumstein/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+# no tests