summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 03:53:54 +0000
committerSam James <sam@gentoo.org>2021-03-04 03:53:54 +0000
commit2e99c25c0fbdd9899a3e67aa73c0264da66ea56a (patch)
treed74ad677cfb4af3a0e67057377f0072691071939 /dev-python/nose_fixes/nose_fixes-1.3.ebuild
parentdev-python/oauth2: mark ALLARCHES (diff)
downloadgentoo-2e99c25c0fbdd9899a3e67aa73c0264da66ea56a.tar.gz
gentoo-2e99c25c0fbdd9899a3e67aa73c0264da66ea56a.tar.bz2
gentoo-2e99c25c0fbdd9899a3e67aa73c0264da66ea56a.zip
dev-python/nose_fixes: add Python 3.9, modernise
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/nose_fixes/nose_fixes-1.3.ebuild')
-rw-r--r--dev-python/nose_fixes/nose_fixes-1.3.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/dev-python/nose_fixes/nose_fixes-1.3.ebuild b/dev-python/nose_fixes/nose_fixes-1.3.ebuild
index 75ea4bb0fdbd..599a6bd318a3 100644
--- a/dev-python/nose_fixes/nose_fixes-1.3.ebuild
+++ b/dev-python/nose_fixes/nose_fixes-1.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
@@ -16,15 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-RDEPEND="
- dev-python/nose[${PYTHON_USEDEP}]"
-DEPEND="
- ${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pkginfo[${PYTHON_USEDEP}]
- )"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-distutils_enable_sphinx docs \
- dev-python/pkginfo
+distutils_enable_sphinx docs dev-python/pkginfo
distutils_enable_tests nose