summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2018-10-15 04:06:13 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-22 21:58:50 +0200
commit3bbeca687c64c12a9b978f6e9cdf8e106f2aee36 (patch)
treeadf6a90bd5cfe2631600cbd710f501baefe31e99 /dev-python/nuitka
parentuse.desc: Remove unused global 'mozilla' flag (diff)
downloadgentoo-3bbeca687c64c12a9b978f6e9cdf8e106f2aee36.tar.gz
gentoo-3bbeca687c64c12a9b978f6e9cdf8e106f2aee36.tar.bz2
gentoo-3bbeca687c64c12a9b978f6e9cdf8e106f2aee36.zip
dev-python/nuitka: add new package
Nuitka ia a Python compiler with full language support and CPython compatibility. This Python compiler achieves full language compatibility and compiles Python code into compiled objects that are not second class at all. Instead they can be used in the same way as pure Python objects. Using Nuitka allows one to create C based modules to be used in larger Python project or a stand alone executable of a Python code base. Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10068 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/metadata.xml21
-rw-r--r--dev-python/nuitka/nuitka-0.6.0.4.ebuild29
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
new file mode 100644
index 000000000000..d2b989e626fb
--- /dev/null
+++ b/dev-python/nuitka/Manifest
@@ -0,0 +1 @@
+DIST Nuitka-0.6.0.4.tar.gz 2010373 BLAKE2B 96d31fde6d087bea81051bfcc208d52466b9c45785c2167c61721440fe930906958ee840bb98258c7c1b98c067302049afd63bbf5cfd422a69c1994675c29c70 SHA512 f9a30ad578b80679c0313be84150adff83a90b35c758487fc9f5240d527cf0a905b6257a0dfdf2a2c8c7322688108a6673c56238480344adce123d67416eb197
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
new file mode 100644
index 000000000000..a082b06e69cd
--- /dev/null
+++ b/dev-python/nuitka/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ Python compiler with full language support and CPython compatibility
+ This Python compiler achieves full language compatibility and compiles Python
+ code into compiled objects that are not second class at all. Instead they can
+ be used in the same way as pure Python objects.
+</longdescription>
+<upstream>
+ <remote-id type="github">pwman3/pwman3</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/nuitka/nuitka-0.6.0.4.ebuild b/dev-python/nuitka/nuitka-0.6.0.4.ebuild
new file mode 100644
index 000000000000..f90b09327492
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6)
+inherit distutils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="http://www.nuitka.net"
+SRC_URI="http://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ elog "nuitka needs app-admin/chrpath for building"
+ elog "stand-alone executables"
+}