summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-14 19:11:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-14 19:14:17 +0300
commit77a68b5bc47f4dc25886e486b729c9d3ba8915e0 (patch)
tree5bcc7dc3710ee9897017fd813420c4819d3429f3 /dev-python/nuitka
parentsci-libs/eccodes: enable py3.10, py3.11 (diff)
downloadgentoo-77a68b5bc47f4dc25886e486b729c9d3ba8915e0.tar.gz
gentoo-77a68b5bc47f4dc25886e486b729c9d3ba8915e0.tar.bz2
gentoo-77a68b5bc47f4dc25886e486b729c9d3ba8915e0.zip
dev-python/nuitka: add 1.1.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.1.5.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index a17151a93f5f..a1cf434133f5 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-1.1.3.tar.gz 3921812 BLAKE2B f3160facc010fb55510246d8c455665c9be1c893629a04ecfd204fcd6898ae6e4955684804cc83abff8e35084727c87b848abd9d5c25f8d0eb5b054b1c2f7d5a SHA512 fcc1374605ae8429a3f22c926783d8f96b335597b152320d2a33152ccabb7e3cb003f7870d51dcf36d1e4bbc391f517e56631c49905a4bd1cc146e5ada9c5aa6
DIST Nuitka-1.1.4.tar.gz 3923043 BLAKE2B 7c85aab9170f118f43c56a097ef4ea90e78e539d8a796fcf4435f1e2d27e1f8a7f87ab030736f231834ab044db512e6649f6f0f2b7726dcda989edad5cc9cbae SHA512 9bf9de077d71cdca629737f21ddac22fa8526d4e1d3ec3a41465f8764997141a3a5e6e2d545001b72f66dc972fe7a9fa23cdf36636a29552652d1a04a23fd2d6
+DIST Nuitka-1.1.5.tar.gz 3920916 BLAKE2B 7352009df91e39c63073e8230065af990c86d07cf51752ceaf234e4e8b5814d085ee7423440dc5bb8ca63341f7e1eccdbd41631711ebcfac481bcb3645c011f2 SHA512 ef88b98341cb930529d6e31bb487cf3bb8c217dd9b8a8b50c8e5b147f0b4879a17f2d6c7621a056ad3f1ffd15ac88781445bc0dc8dc164a38aea83b43a6bf3c7
diff --git a/dev-python/nuitka/nuitka-1.1.5.ebuild b/dev-python/nuitka/nuitka-1.1.5.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.1.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}