summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2019-02-19 05:21:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:12 +0100
commitb2257ba0517ae47b2c18c09be7c0b82fe3bd7cb1 (patch)
tree3a9e8b06355d8f8e8657f8128043d78bc5d3ad59 /dev-python/nuitka
parentgames-simulation/openrct2: update objects versions. (diff)
downloadgentoo-b2257ba0517ae47b2c18c09be7c0b82fe3bd7cb1.tar.gz
gentoo-b2257ba0517ae47b2c18c09be7c0b82fe3bd7cb1.tar.bz2
gentoo-b2257ba0517ae47b2c18c09be7c0b82fe3bd7cb1.zip
dev-python/nuitka: version bump to 0.6.2.
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://bugs.gentoo.org/678320 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11104 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 9609e008c67b..328995bf08d2 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-0.6.0.4.tar.gz 2010373 BLAKE2B 96d31fde6d087bea81051bfcc208d52466b9c45785c2167c61721440fe930906958ee840bb98258c7c1b98c067302049afd63bbf5cfd422a69c1994675c29c70 SHA512 f9a30ad578b80679c0313be84150adff83a90b35c758487fc9f5240d527cf0a905b6257a0dfdf2a2c8c7322688108a6673c56238480344adce123d67416eb197
DIST Nuitka-0.6.0.6.tar.gz 2011509 BLAKE2B 1a5d37acd50bbb7d1a380306aa18d68ab6559fe3d90b988032cd36458e5ec663c2ba1597f50da89c6b2360f35cd576a2219860b0d74bb3d835db9525d10f22bf SHA512 d893e49a2f91d310b4a86ddd1566990b66ae202bde642af8b7e45554ed6b2abf4b6b694bb03d020b15d9b748c0dd31ac1a79c77fcc9d15468ce37faf475e8beb
+DIST Nuitka-0.6.2.tar.gz 2064701 BLAKE2B 9144bbae98584c64a642ede1155f26f88afa1ffe6d1e75f88039fe99f191e0939efc5ce7e71b2b9c661004213990e4896a392e2fce995a0649d45ed5b3a18168 SHA512 94547cdabaf6c591ff5d49179dc4538fa624b40a6d63e318aeabe371b7cfdbd9b1c9c41918a4ea1dfa816a7222c5587ed17c1980d89be6d9151ecc8cdaa8c5a5
diff --git a/dev-python/nuitka/nuitka-0.6.2.ebuild b/dev-python/nuitka/nuitka-0.6.2.ebuild
new file mode 100644
index 000000000000..306034cd1e10
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}