summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-07 05:43:44 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:26:38 +0000
commit3e2244697d5640b5875d20854248d3180d56dbca (patch)
tree94158dcf1e846b6ba7142da7bc1f810b16d9b2b6 /dev-python/numba/numba-0.30.0.ebuild
parentdev-php/PEAR-Net_DNSBL: new EAPI=6 revision. (diff)
downloadgentoo-3e2244697d5640b5875d20854248d3180d56dbca.tar.gz
gentoo-3e2244697d5640b5875d20854248d3180d56dbca.tar.bz2
gentoo-3e2244697d5640b5875d20854248d3180d56dbca.zip
dev-python/numba: version bump
removed doc building for now. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/numba/numba-0.30.0.ebuild')
-rw-r--r--dev-python/numba/numba-0.30.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/numba/numba-0.30.0.ebuild b/dev-python/numba/numba-0.30.0.ebuild
new file mode 100644
index 000000000000..5798de58f5b5
--- /dev/null
+++ b/dev-python/numba/numba-0.30.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
+HOMEPAGE="http://numba.pydata.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/llvmlite-0.15[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( virtual/python-singledispatch[${PYTHON_USEDEP}] )
+"
+# doc building highly broken
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c "import numba; numba.test()" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}