summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-10 16:29:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 17:43:21 -0500
commit3b502139f02955d99fc9a829a737554b1fdef418 (patch)
tree939773632d4266c96ddf6aa29c2608c9ef88cade /dev-python/oauth2client
parentdev-python/decorator: 4.3.2 bump (diff)
downloadgentoo-3b502139f02955d99fc9a829a737554b1fdef418.tar.gz
gentoo-3b502139f02955d99fc9a829a737554b1fdef418.tar.bz2
gentoo-3b502139f02955d99fc9a829a737554b1fdef418.zip
dev-python/oauth2client: 4.1.3 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oauth2client')
-rw-r--r--dev-python/oauth2client/Manifest1
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oauth2client/Manifest b/dev-python/oauth2client/Manifest
index a275df3d0b5f..74bde410e8e6 100644
--- a/dev-python/oauth2client/Manifest
+++ b/dev-python/oauth2client/Manifest
@@ -1,3 +1,4 @@
DIST oauth2client-2.0.1.tar.gz 153127 BLAKE2B f7e7ccbe42effedfb94abe4f78e2ea02867aa75ca7ff794d6db6cdb2e039d4a7d55df79df3a7f8777be215fc4aafb1dda08a23b81eaa66d64c9b2580045c158f SHA512 66179a604418a8aee9ca9dbfc5ad18356d5130a588e85f4dab3330feef194af2114bc2eb18ec625acf791938e4d7f78ee55284f45a67a48c775676697ce2b183
DIST oauth2client-2.2.0.tar.gz 167484 BLAKE2B 60c7fc941548874f436df094a94e97312983f88af8ca472c998cb7121662363793423d420fa3e7e83032b82a3fd22a76f9331a60e3099785ef82d3fb5a781356 SHA512 1e23c3f655e955dbf0cdb2b78613768ca4c6eb4336b555e3553da212fd762ba12329584f108d8145810228cf44da018675b38dd152b06e58be4eb18d4f8127c6
DIST oauth2client-4.1.2.tar.gz 184731 BLAKE2B 09ae16a94b1f6b3eedb02ac10d660d8fda78faa82da5fed75b2a40308049c7d78951d593352f2e02c7bd9255e75b50c20996d12f451c20e1dcf2c32f54008b07 SHA512 908f0e32f0ef76c3eb86ee34118d4100bc08fa34aa89c561793bf8c55078f07611935ee6aecb6d2ae2f7e96a18ac3bc25af0321fe564f26042ff2bb5eab30b18
+DIST oauth2client-4.1.3.tar.gz 185589 BLAKE2B 6cd61448e0d55cef7f2ba640c8cbb50ac83e76d0993391eb0acb3e156f937fcdee80576c9d45d505235a9f266495069664ccbfafd649a4e2d7a0990517ee8cb6 SHA512 80f49e09a6dd6767307a2c278544926fbf20b4f55e4cf83563ac7a7c1043622bd3c8c7fcf6de62896b623ca8c7947b309a5e6bf2b7cb0fccff3ff7634386b287
diff --git a/dev-python/oauth2client/oauth2client-4.1.3.ebuild b/dev-python/oauth2client/oauth2client-4.1.3.ebuild
new file mode 100644
index 000000000000..86f44564fc75
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-4.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+REQUIRED_USE="|| ( $(python_gen_useflags 'python*') )"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/keyring[${PYTHON_USEDEP}]' 'python*')
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${P/_p/-post}
+
+python_prepare() {
+ # keyring is not fuly supported by pypy yet, because dbus-python can't support pypy
+ # oauth2client -> keyring -> secretstorage -> dbus-python
+ # https://github.com/mitya57/secretstorage/issues/10
+ case $PYTHON in
+ pypy|*pypy|*pypy3|pypy3) \
+ find "${BUILD_DIR}/.." -name '*keyring*py' -delete ;;
+ esac
+}
+
+python_test() {
+ nosetests -e appengine -e django_util -e test_multiprocess_file_storage -e test_bad_positional || die
+ # appengine - requires appengine
+ # django_util - requires django
+ # test_multiprocess_file_storage - requires fasteners
+ # test_bad_positional - expects TypeError, gets ValueError
+}