summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 10:13:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit9243a357eb02afd657d3564325347e48e27aaf4a (patch)
tree0f6c04d2a76d1bfcf32ff1245aebde976abd9ba1 /dev-python/oauthlib
parentdev-python/netifaces: Add python3.5 support (diff)
downloadgentoo-9243a357eb02afd657d3564325347e48e27aaf4a.tar.gz
gentoo-9243a357eb02afd657d3564325347e48e27aaf4a.tar.bz2
gentoo-9243a357eb02afd657d3564325347e48e27aaf4a.zip
dev-python/oauthlib: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-python/oauthlib/oauthlib-1.0.1.ebuild b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
index 335037b17bd7..63579d2617ae 100644
--- a/dev-python/oauthlib/oauthlib-1.0.1.ebuild
+++ b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
-DESCRIPTION="A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
HOMEPAGE="https://github.com/idan/oauthlib https://pypi.python.org/pypi/oauthlib"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
@@ -17,12 +18,14 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"
# optional extras hard set as RDEPs. See setup.py
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)