summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-26 15:12:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-26 18:07:08 -0700
commit747ae321d9f4e638cb29bf4ec6268cb7b3211bfe (patch)
tree9f156f7762b47f4e5ce0dd795e9fddcba58095c9 /dev-python/objgraph
parentdev-python/pure-sasl: New package (diff)
downloadgentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.tar.gz
gentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.tar.bz2
gentoo-747ae321d9f4e638cb29bf4ec6268cb7b3211bfe.zip
dev-python/objgraph: Version bump to 3.4.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/objgraph')
-rw-r--r--dev-python/objgraph/Manifest1
-rw-r--r--dev-python/objgraph/objgraph-3.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/objgraph/Manifest b/dev-python/objgraph/Manifest
index 4080ab53bff7..5b40e1d17e4f 100644
--- a/dev-python/objgraph/Manifest
+++ b/dev-python/objgraph/Manifest
@@ -1,3 +1,4 @@
DIST objgraph-1.7.2.tar.gz 545016 BLAKE2B a124e5fff089704a7ec24a0e4983e8ab52a074a557a5b885f57819bf2ea5cc667ef0b007931b32be131ee56cb9d39798b20f999670ce7112b4f906c151298ce8 SHA512 22012031723060b47058c00cd97035b53238f8cf49c4e51b1f7735bf9c1d5aac9a5f0bcbe605317952f9b9390fc3bf247211082b4540e05cbf76670c27861ac2
DIST objgraph-1.8.1.tar.gz 549402 BLAKE2B 8694f051c9771f27aba0d6927ca15b230a388a6b9d153e9b7ea8e9878283165a4444850e9774c58fd0185b5debfe8aa85d6f94c838d0beb477ed98820312e205 SHA512 c09e66aecc5dadc5a6e3d93e0f97fa6e816c5cbe968540400ed3d1248b958c955648cb2b4247ba00cd2388302dbcc178c55686cd2b95858b965a2717c6ff0c90
DIST objgraph-3.1.0.tar.gz 629772 BLAKE2B afa34613d8b05399dec1429465d81b026000ac22c0d345289ce7b2c9c7cc0a0bb6db0054bc7f92ab8d0c69e2d40cf860dc46350951251c106e7718daa8efa0fc SHA512 4b997ff1942556fdeece39080ad00d915136d314add94e61e4b3102e332ce3fd029f7082fbbadeffae63f157f05f8af4871dc5b7ee26926d790fb043ad8f2130
+DIST objgraph-3.4.0.tar.gz 634554 BLAKE2B d1e58370a50a9c9d8647c7633a780069581eec61cccef56e83b015f26a7ffbba6b872673d72dc138339b3c97a3f08c02067e203ddb1d1048ae6f3611e0837fca SHA512 f1e2b9f22dfdce56988bd40aaa865572c42688e73800bb7c188b903c67ef3726c03ba058ed30d40792133a2e2fe74d5ecda91be3de8cf7b80188ac0b9f6ac393
diff --git a/dev-python/objgraph/objgraph-3.4.0.ebuild b/dev-python/objgraph/objgraph-3.4.0.ebuild
new file mode 100644
index 000000000000..9a701f9fbbdf
--- /dev/null
+++ b/dev-python/objgraph/objgraph-3.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="https://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="dev-python/setuptools
+ test? ( media-gfx/xdot )"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+ distutils-r1_python_install_all
+}