summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-17 21:05:38 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-17 21:17:02 +0100
commite1d44f9693d131e6f5f8668e515542f14f7b57e6 (patch)
treeed7370956c1f06b4ac4808ba3d8da063a370c125 /dev-python/odfpy
parentwww-apps/chromedriver-bin: bump to 87.0.4280.20 (diff)
downloadgentoo-e1d44f9693d131e6f5f8668e515542f14f7b57e6.tar.gz
gentoo-e1d44f9693d131e6f5f8668e515542f14f7b57e6.tar.bz2
gentoo-e1d44f9693d131e6f5f8668e515542f14f7b57e6.zip
dev-python/odfpy: Port up to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/odfpy-1.3.6.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/dev-python/odfpy/odfpy-1.3.6.ebuild b/dev-python/odfpy/odfpy-1.3.6.ebuild
index ce7cc64b9f96..d04250e5a2a1 100644
--- a/dev-python/odfpy/odfpy-1.3.6.ebuild
+++ b/dev-python/odfpy/odfpy-1.3.6.ebuild
@@ -3,10 +3,7 @@
EAPI=7
-# Classifier: Programming Language :: Python :: 2 :: Only
-# py3 fails one test, pypy anpother.
-# Notes on page of home repo reports support of python3.
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -17,16 +14,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- pytest -v || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests pytest
python_install_all() {
if use examples; then