summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ordereddict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ordereddict')
-rw-r--r--dev-python/ordereddict/Manifest1
-rw-r--r--dev-python/ordereddict/metadata.xml15
-rw-r--r--dev-python/ordereddict/ordereddict-1.1.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ordereddict/Manifest b/dev-python/ordereddict/Manifest
new file mode 100644
index 000000000000..c0972ec575a2
--- /dev/null
+++ b/dev-python/ordereddict/Manifest
@@ -0,0 +1 @@
+DIST ordereddict-1.1.tar.gz 2114 SHA256 1c35b4ac206cef2d24816c89f89cf289dd3d38cf7c449bb3fab7bf6d43f01b1f SHA512 20b2beb1ee6309885b2d702c04d21e683fae3061f19176aceae381688be0fed5b2fbf55a1ff901460e93bf14c83169d2b7a286e3725b008583711134656d86e5 WHIRLPOOL 228d1a6a1926d7c1decc892c53d6260e78af0a32fcee2e04ce46a828648a2fcba16ba637b78cd30f903224baadb1ad78b232d0b8f7d68d0bc8c10daebb8ed86c
diff --git a/dev-python/ordereddict/metadata.xml b/dev-python/ordereddict/metadata.xml
new file mode 100644
index 000000000000..4c42f6a05cf7
--- /dev/null
+++ b/dev-python/ordereddict/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A drop-in substitute for Py2.7's new collections.OrderedDict that works in Python 2.4-2.6.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ordereddict</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ordereddict/ordereddict-1.1.ebuild b/dev-python/ordereddict/ordereddict-1.1.ebuild
new file mode 100644
index 000000000000..1d145cb8bc12
--- /dev/null
+++ b/dev-python/ordereddict/ordereddict-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop-in substitute for Py2.7's new collections.OrderedDict that
+works in Python 2.4-2.6."
+HOMEPAGE="https://pypi.python.org/pypi/ordereddict"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""