summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/oslo-cache
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest1
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.14.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index 4372a6ed7964..a2c4f57ae346 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1 +1,2 @@
+DIST oslo-cache-1.14.0.tar.gz 45780 SHA256 3ba84b421f80c5a6609789cf17b1da86aab465a96e68298620e839fafec3f0be SHA512 b3638e1cec577bc3779595288ff323baef7b08e534050771ffef80aed9d61e1cb6fc9c034c753768e401f313fba8f7aa0b2f6a3354f272e2498d3972abbcdfd0 WHIRLPOOL 966bde82c0aefe8ea09e8e984ea6c769c983b5ce38d9b4a3b6e4921b66a8b261d81f8dfde4295099234da97bd887c0b00714bf454e634f356d81ba6a574557ca
DIST oslo-cache-1.6.0.tar.gz 36037 SHA256 c357671fb642822924d063b8151e132a6e7a65189c6c35c3f22c64ae0b0bdda8 SHA512 48ea43142d8221a61556ccccbb3c64e8708a1af04514b28dc22049a84d00e14253c9577d05321ef6de62ddc9120789942a82f231f1d7eeca2e5adf2d92ae04d5 WHIRLPOOL 8d06791e971fd6d9e3f49ade330b3c2ad780b162f953a5f9f04d40568efac7b38ae997f53ba315c38af59715d8be95cbab3dd3df051fa1b685b763476bbaf5a6
diff --git a/dev-python/oslo-cache/oslo-cache-1.14.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.14.0.ebuild
new file mode 100644
index 000000000000..de67eb654b1e
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.14.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}