summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:21:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:03 -0500
commit7dbdf1aeb3ed5fd6a82f8893dd5da62f0887fde0 (patch)
tree96293e1c056f6b5900343d9837e44386edbebd8c /dev-python/oslo-cache
parentdev-python/oslo-db: 4.45.0 bump (diff)
downloadgentoo-7dbdf1aeb3ed5fd6a82f8893dd5da62f0887fde0.tar.gz
gentoo-7dbdf1aeb3ed5fd6a82f8893dd5da62f0887fde0.tar.bz2
gentoo-7dbdf1aeb3ed5fd6a82f8893dd5da62f0887fde0.zip
dev-python/dogpile-cache: add py37 to 0.7.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest1
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.33.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index 22f3e2756ed0..55c1a5918811 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1 +1,2 @@
DIST oslo-cache-1.30.3.tar.gz 53116 BLAKE2B 0b63f828f61dd82b69efe7a6e345974c56b2e980d88f159dd7c3ba5484cd1e8f78a393a7f73a6f2152db1c30178a054e2f20d753a286a0cd8f7d83af7f623bf2 SHA512 3ab9842cd388a846fe9004b97364057245936b9af185ba0f68e6d6bcc750dd957eb873d45e686cddeec94fda6872b72e4549c71ebc9e1de4755504c2a138b85c
+DIST oslo-cache-1.33.2.tar.gz 55778 BLAKE2B e75fea8b669d30efdf72bd565deb560dfe2c1627e4bca74ffbce923341e5663d641ae44b144e070e4af7587c08e911a4b025ffd0ca1bbc39dfc4ed3266cde1c8 SHA512 8111ba9f62724ff6ee64750a88807e40a38252273669c96b86dedd0e36f2d1661f54fd55bc462ffa577e95771d08965ad6be208224d442306d869db2d155da91
diff --git a/dev-python/oslo-cache/oslo-cache-1.33.2.ebuild b/dev-python/oslo-cache/oslo-cache-1.33.2.ebuild
new file mode 100644
index 000000000000..698c1adebd8b
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.33.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}