summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:01:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:01:27 -0500
commitd8870bd2c92a973d5750fc0a960abfce38fde615 (patch)
tree488b205a69db41217c12d465ea48b1f186afdf89 /dev-python/oslo-cache
parentdev-python/oslo-log: bup mitaka (diff)
downloadgentoo-d8870bd2c92a973d5750fc0a960abfce38fde615.tar.gz
gentoo-d8870bd2c92a973d5750fc0a960abfce38fde615.tar.bz2
gentoo-d8870bd2c92a973d5750fc0a960abfce38fde615.zip
dev-python/oslo-cache: new for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest1
-rw-r--r--dev-python/oslo-cache/metadata.xml11
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.5.0.ebuild40
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
new file mode 100644
index 000000000000..647f374e55c2
--- /dev/null
+++ b/dev-python/oslo-cache/Manifest
@@ -0,0 +1 @@
+DIST oslo-cache-1.5.0.tar.gz 36204 SHA256 a8810cac4b53535e26d9c12c75c49e08387c54577f2973379a8ff4bba45f418d SHA512 aeb9ec97c9b964b1a897b929426082a6a3900dca9b6e86a203338603fc94b57d3327e79a1b6ee2bb9364041b014e8a5b9e3ea330937d79f32ff111115fb3af0b WHIRLPOOL c0c1fa549f656b7eddafc08b1611690adb46b2ac0f4be1f44efc265dced9c06ec9744e0e923f2c857d00b4526fbcbc7fb13711734ac4a33a17116a376ce4830b
diff --git a/dev-python/oslo-cache/metadata.xml b/dev-python/oslo-cache/metadata.xml
new file mode 100644
index 000000000000..4688c947896d
--- /dev/null
+++ b/dev-python/oslo-cache/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Wraps the dogpile.cache library
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/oslo-cache/oslo-cache-1.5.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.5.0.ebuild
new file mode 100644
index 000000000000..2fe2236a0ad1
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.7[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}