summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-24 19:00:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-24 19:07:02 -0500
commita547e14aff9d483af6ca37b246d5343e297cf4f2 (patch)
tree6d5784175e25f981693520c473112f7f41844a46 /dev-python/oslo-concurrency
parentdev-python/oslo-context: remove pike/queens (diff)
downloadgentoo-a547e14aff9d483af6ca37b246d5343e297cf4f2.tar.gz
gentoo-a547e14aff9d483af6ca37b246d5343e297cf4f2.tar.bz2
gentoo-a547e14aff9d483af6ca37b246d5343e297cf4f2.zip
dev-python/oslo-concurrency: remove pike/queens
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index ec9fef31ba5a..01a12bcb1fd5 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,2 +1 @@
-DIST oslo.concurrency-3.25.1.tar.gz 49218 BLAKE2B 95fccb051ef782a0b6cd01801e9b44272a8b04ca52fd0f00f91a2aa3514885c302a3f251885f59c32303708c91331f3f59ee06ebdce4751d013559a0e7d19b16 SHA512 5c306e742c652d66209a3218ccdc1d1f957ec6fde0b0bcb9411a71e470e8c0402c4cc1a40a05094ce591942ed16b8e0a7b456d60a64e0299ef32a257b37c8388
DIST oslo.concurrency-3.27.0.tar.gz 49604 BLAKE2B 04a7ed66c6d7cf37014080113bd3782cf186f57f486d6834fd28f3d518141f8dcac6f5e67ffb5ef894bc6f5085a90aa41a041e35b72325c645f7567dd743a912 SHA512 fb2e1377a8bbad451ef0a2713dfbcd58ec06d455e97fc4d8acf8bfde8eb27d59826d68dd3411bd60b6d6b5e68ff629f0e6e4781b17dd4349bc5b87f17c8b9d52
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild
deleted file mode 100644
index e4343f6c9327..000000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="library for running multi-thread, multi-process applications"
-HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
-S="${WORKDIR}/oslo.concurrency-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- virtual/python-enum34[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^futures/d' test-requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
-}