summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:39:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:54:06 -0500
commit6ca5d73d1dffeccb1e07cde2aac7b7554d1066c0 (patch)
tree526e709b9e40b52bdd5e7f6d9922655f610842f6 /dev-python/oslo-serialization
parentdev-python/oslo-middleware: 4.0.2 stable amd64/x86 with cleanup (diff)
downloadgentoo-6ca5d73d1dffeccb1e07cde2aac7b7554d1066c0.tar.gz
gentoo-6ca5d73d1dffeccb1e07cde2aac7b7554d1066c0.tar.bz2
gentoo-6ca5d73d1dffeccb1e07cde2aac7b7554d1066c0.zip
dev-python/oslo-serialization: 3.1.1 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-serialization')
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild77
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-3.1.1.ebuild2
3 files changed, 1 insertions, 79 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index e18628a334a4..08f8fc664147 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1,2 +1 @@
-DIST oslo-serialization-2.28.2.tar.gz 30807 BLAKE2B ff0ee4d4215943d0fa419d0d0989c093812d354da6727f5e87a27ff0562baf5e3a22c781c686ce5156fcff065e03c7481bcf3e16041a2296366a1f297060eff5 SHA512 78305f20392348b73eca244464cd4167177cd82ea74597641ee9de60b51182e5e3d75e5d748fe2c39ddb322a08f2ee5044c846bc969022b738a0b89874451337
DIST oslo-serialization-3.1.1.tar.gz 32180 BLAKE2B 5ce0db206732430b2553b0eb01d5df717069a07370a20ef452b77e83ed95f1cd0542eac287ba28d4fd2a3f66541823c362a925e48a3ed175abdbab2c1aa5b2f2 SHA512 5a551c33a001eeb73213dac1b4e4bc50db2ceb7dc2f9881c07abbab05cc8ccfda4d73cc9bdc673e26628aaa05c3d66f9c76ba4eb370c851990f3614b33233a95
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild
deleted file mode 100644
index 0179307703c9..000000000000
--- a/dev-python/oslo-serialization/oslo-serialization-2.28.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Serialization library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
- >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # allow useage of renamed msgpack
- sed -i '/^msgpack/d' requirements.txt || die
- use doc && esetup.py build_sphinx
- distutils-r1_python_prepare_all
-}
-
-# Note: Tests fail due to requiring installation.
-#
-# Installation appears to fail due ot the use of namespace packages but root
-# cause was never truly established.
-RESTRICT="test"
-
-python_test() {
- distutils_install_for_testing
-
- PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/oslo-serialization/oslo-serialization-3.1.1.ebuild b/dev-python/oslo-serialization/oslo-serialization-3.1.1.ebuild
index 2b721387653a..f5f4d9cb8de3 100644
--- a/dev-python/oslo-serialization/oslo-serialization-3.1.1.ebuild
+++ b/dev-python/oslo-serialization/oslo-serialization-3.1.1.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE=""
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]