summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 19:15:08 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:15:08 -0600
commitf7fac187010aa4303360fed4aa86219f6749a067 (patch)
treebcbcec230b3d98e5e1135020e8a202bc92ce56c4 /dev-python/oslo-serialization
parentdev-python/oslo-log: bup (diff)
downloadgentoo-f7fac187010aa4303360fed4aa86219f6749a067.tar.gz
gentoo-f7fac187010aa4303360fed4aa86219f6749a067.tar.bz2
gentoo-f7fac187010aa4303360fed4aa86219f6749a067.zip
dev-python/oslo-serialization: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/oslo-serialization')
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.16.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index 4ebafa65c284..b0c3bf591d42 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1,2 +1,3 @@
DIST oslo-serialization-1.11.0.tar.gz 20612 SHA256 b9a5b8bd4583957476464016f1c4d3ca01a30a0125acb1cd0ddd830715c88e1f SHA512 0fbe6282f26678208c22d31e6c221d63173688151b1eb228fd1dbbc184973c1039c43efa8d4f67f7f99dc3263d46021e6f0b7efcfbc4c13515d4a4d0f55cf0c2 WHIRLPOOL 3adb4c481ed8b8b789714b2d182b43cb7e948cfc49a73380c5abd3f662f00d10f8a10a41596f31c5a3ec98e75bbd170692a6fc8f720875fd4fe35d1b23df8e7a
DIST oslo-serialization-2.13.0.tar.gz 23273 SHA256 7bfdb1c10bc24c4887407a2ac46708b1fd16e9bc2ceb6bb3805696e8cebf6566 SHA512 0cbcc650c06a7468986971c92674ebb6ad66355c05584a9bb78099bb185818cf9a61fc44a98dada6e6879037cc54596d7095069ba1ce4e7e5ceb9348ea31a493 WHIRLPOOL 2ccb79d37b132af08b8c9174394f6c006587eeb8b69a94ef5af06e1fb85180e34ff652b3ce04c372c06808cedcae92183b56b26fc044e20f51080c664b8f58c2
+DIST oslo-serialization-2.16.0.tar.gz 28204 SHA256 0ef8dfa735a42dcfd7d804c5b14576df92407f842d5e12c1fad7eb0889c444fc SHA512 d6612d99e05e3c634d8b2a2e37183884f7aeec3608080bc2bbfcd8e436a64a678e1bb294024ddec0d276fc216fa92a9117a63eb085bc110500e07f1db172e5b0 WHIRLPOOL 5d43524577569a2ee194bc92f387fad10bf15e6922fa315f9559d6a7a6ecba95dfd977f30e7a9086e6120e38fc56f83d37e64f25bc113b6f212f03753f355cbd
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.16.0.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.16.0.ebuild
new file mode 100644
index 000000000000..6a5692c198ba
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-2.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+ distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}