summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-18 09:50:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-18 10:12:46 +0100
commit332748d81f6707e50e78f822c483892d5de206fd (patch)
tree29eae33b64cfb83cf76e4f4780d7924524af6dfb /dev-python/oslo-utils
parentapp-portage/eix: Remove old (diff)
downloadgentoo-332748d81f6707e50e78f822c483892d5de206fd.tar.gz
gentoo-332748d81f6707e50e78f822c483892d5de206fd.tar.bz2
gentoo-332748d81f6707e50e78f822c483892d5de206fd.zip
dev-python/oslo-utils: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-utils')
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-4.1.2.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 670b655a8462..813b74056624 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1,2 +1 @@
-DIST oslo-utils-4.1.2.tar.gz 92889 BLAKE2B 16397708abe47946c1495adf6b91ad9db6bdef8c2f475f398b3b4d390193b800ff0b1710183732b81dde89fc24aad204854d02a0e0567046e712663eaa685711 SHA512 d6784c7e1a30690ec2523514b464c95e1d6704a8c8fef5da85b76583dfb5d4b5cbfd18eb9451a90243210e50405f7541b85b39ac09d4f487119677efeef63418
DIST oslo-utils-4.6.0.tar.gz 94148 BLAKE2B 2de92b22b849522a43e81f0fa9bb5e92d2c380c07eca81cd916c536e10ec55869d5933a3a9dcc65b682ac793534094e6b0aaa74b7ac9c74724231dccc0dbae3b SHA512 fe91522c9860a7637af8b8521c297d6467f2af643f026abc97b72fd3032789219d2b3fdc9a6d8beecb0e55e4e7c319e800be295abf9639b52e32da81dae0c9a7
diff --git a/dev-python/oslo-utils/oslo-utils-4.1.2.ebuild b/dev-python/oslo-utils/oslo-utils-4.1.2.ebuild
deleted file mode 100644
index 7a5cefe94e82..000000000000
--- a/dev-python/oslo-utils/oslo-utils-4.1.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Utility library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.18.3[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- <dev-python/bandit-1.6.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-# Note: Tests fail due to requiring installation
-#
-# Installation appears to fail due to the use of namespace packages but root
-# cause was never truly established.
-#
-# Tests fail with:
-# ImportError: No module named 'oslo.utils
-
-#RESTRICT="test"
-
-python_test() {
- distutils_install_for_testing
-
- cd "${TEST_DIR}"/lib || die
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}