summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-11 12:36:58 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-11 13:06:08 -0600
commit8a226aed49c7639e2efc898c43d29a9578877dae (patch)
tree0eb7c5e60e70a4511cab35d5b77f2d058b96d2f8 /dev-python/oslotest
parentdev-python/oslo-vmware: cleanup (diff)
downloadgentoo-8a226aed49c7639e2efc898c43d29a9578877dae.tar.gz
gentoo-8a226aed49c7639e2efc898c43d29a9578877dae.tar.bz2
gentoo-8a226aed49c7639e2efc898c43d29a9578877dae.zip
dev-python/oslotest: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/Manifest1
-rw-r--r--dev-python/oslotest/oslotest-3.2.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index d0f1e89d22fe..1487fd07ffd9 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1,2 +1 @@
-DIST oslotest-3.2.0.tar.gz 35445 BLAKE2B d33c70e760fc595586c2d7b0ce6ed1f63b73c89ba078f85b70d3b6b1af1c4d115e6eb7b431f9ef52abf50290eb47a1d3adb2d014c2ba5cf7b93ecf0e46401a26 SHA512 4513291e2bec939f9734255cb0fe3f85b9eb8a8cadce58873ad4e85365a0ec27bc2084085f5b95b681b5e811b62458e18fe63aff1e022b2d8ace0ca48bd6a527
DIST oslotest-3.7.1.tar.gz 38176 BLAKE2B 94924dca8384dcc8ba9e4f62220eb6d29b27b38966ffce7dddbd23d5c5e66493141ce4170565325a0516648db186a0171cd33de6d536bb8ed5cdef76161d4f94 SHA512 dfc55bc91ebd8ef448d4c69b2af51b8f2a9f2068b2ef2ec1cfbcfffc27eff7ccafb00dc2a3059730427aecbcd815f9dee2f00b8c74df154c8dbb95793aff7e78
diff --git a/dev-python/oslotest/oslotest-3.2.0.ebuild b/dev-python/oslotest/oslotest-3.2.0.ebuild
deleted file mode 100644
index 9132d32067cd..000000000000
--- a/dev-python/oslotest/oslotest-3.2.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Oslo test framework"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
- >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx -b man
- fi
-}
-
-python_test() {
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- doman doc/build/man/oslotest.1
- fi
-
- distutils-r1_python_install_all
-}