summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 07:31:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 07:31:50 +0200
commit4d40860c6569a96d60585b55095c62e1725cefbf (patch)
tree646e2d9eec4cf9328a2ef58d06d37295de4ccbde /dev-python/osrf_pycommon
parentapp-admin/awscli: Bump to 1.20.10 (diff)
downloadgentoo-4d40860c6569a96d60585b55095c62e1725cefbf.tar.gz
gentoo-4d40860c6569a96d60585b55095c62e1725cefbf.tar.bz2
gentoo-4d40860c6569a96d60585b55095c62e1725cefbf.zip
dev-python/osrf_pycommon: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/osrf_pycommon')
-rw-r--r--dev-python/osrf_pycommon/Manifest1
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-1.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/Manifest b/dev-python/osrf_pycommon/Manifest
index 676acf15222c..59a86e3d2c79 100644
--- a/dev-python/osrf_pycommon/Manifest
+++ b/dev-python/osrf_pycommon/Manifest
@@ -1,2 +1,3 @@
DIST osrf_pycommon-0.1.10.tar.gz 46303 BLAKE2B 3f18b8683a6363e1f15addfe75b8dee31f64fff7c286379d18355dc1f3467063c2cf1a9eb7978c5f9de5d64cb23d18a3922a416fe24fafa618f50f0ba89cddfe SHA512 5d53ea0c3c410a99964330dc22dcbcb3cd8892a359fee2061acc15ddb46e334ff757e8aa5b776fef381246c58e9834003ac818624da4b8e95552f214f3d9e6bb
DIST osrf_pycommon-0.2.1.tar.gz 46633 BLAKE2B ba89f8d783446d52a328d126bcdfac721dba0a811007a55e48ebd3626e58b732d4f03cc2a042d517698d6708bc72e0ffede99ba82604d1f4204ef3c1da36601a SHA512 d05e6bcbb8e7b5506ea953d37c895dbca59765e9a26081aff2c4d213c02365a4254580843dd7624fe4a046afdb2d5b8935c1fcd4d60b6b1d71c4d22789d26371
+DIST osrf_pycommon-1.0.0.tar.gz 45084 BLAKE2B 83bfd5393575a5032e72ae93c9c3eec87d2907ce3fbd3e9fe14a94e5470d61594ab75bca394ec4b7960bbdb16c3ec060966bd6bf47f9a4037d530501c7ce947f SHA512 ff7204116c94eef972b7071f8d6c68fd7cdb1a518fd6c77cd47f54e5390815ff4b6a7d265ef3ed0093c1baa20eb332d69e92926e856da0e34b7186100b688d83
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-1.0.0.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-1.0.0.ebuild
new file mode 100644
index 000000000000..76c71e1f7c8c
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # linting is something upstreams do
+ # for us, it either means unneeded deps or breakage due to changes
+ epytest --ignore tests/test_code_format.py
+}