summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 09:46:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 10:04:55 +0100
commit975bacacf9e40f23f80072fb5b8ea0357975817a (patch)
tree00c5eac30ce60872e628771ec29b1ce5aac55a32 /dev-python/osrf_pycommon
parentdev-python/importlib_metadata: Bump to 4.11.1 (diff)
downloadgentoo-975bacacf9e40f23f80072fb5b8ea0357975817a.tar.gz
gentoo-975bacacf9e40f23f80072fb5b8ea0357975817a.tar.bz2
gentoo-975bacacf9e40f23f80072fb5b8ea0357975817a.zip
dev-python/osrf_pycommon: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/osrf_pycommon')
-rw-r--r--dev-python/osrf_pycommon/Manifest1
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-2.0.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/Manifest b/dev-python/osrf_pycommon/Manifest
index 753f5a7633c2..34446f944791 100644
--- a/dev-python/osrf_pycommon/Manifest
+++ b/dev-python/osrf_pycommon/Manifest
@@ -1,2 +1,3 @@
DIST osrf_pycommon-1.0.0.tar.gz 45084 BLAKE2B 83bfd5393575a5032e72ae93c9c3eec87d2907ce3fbd3e9fe14a94e5470d61594ab75bca394ec4b7960bbdb16c3ec060966bd6bf47f9a4037d530501c7ce947f SHA512 ff7204116c94eef972b7071f8d6c68fd7cdb1a518fd6c77cd47f54e5390815ff4b6a7d265ef3ed0093c1baa20eb332d69e92926e856da0e34b7186100b688d83
DIST osrf_pycommon-2.0.0.tar.gz 45467 BLAKE2B bcf111183b66dd19e24182e6fee75674f0481bdeb2498ea2a0d10c56977651da60f94444706df525ee71f64d5eb1a24e2e5b4acaf13f19f94b787ce5b424c81e SHA512 ebb06a86c3527ea9dfb24778410a7f84d5560216aedd4ed5fe0b22660b6fbf9625d093dc8653db58a2cc7f3a81e6c4a2770fca90694441cdb141fb840935c50e
+DIST osrf_pycommon-2.0.1.tar.gz 45839 BLAKE2B 9961eade38c8de980cee01debbc177ae8ef3ef872d2525c9c6a1660e2323a5bfc02d9f5e6295aeada0cb3a9506da27637eb3c042a1328aff7b5e0e6435bd4dc4 SHA512 9f8affe81c6adc7436ccf9481a84b98a32650c6a0d6bff9c378faf1a9202bfeccb9f72046fecdcdd38f5d6047319db97e6e7e090446ab2fce759949046590f4b
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-2.0.1.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-2.0.1.ebuild
new file mode 100644
index 000000000000..2c0977439143
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # linting is something upstreams do
+ # for us, it either means unneeded deps or breakage due to changes
+ epytest --ignore tests/test_code_format.py
+}