summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-23 14:17:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-23 14:19:35 -0500
commit7673eb73a22aadefe9602b59e924f7a3bbb2887d (patch)
tree2b0927ac61c5ebe9a538122d33c9e8f293afd93a /dev-python/ovs/ovs-2.13.0.ebuild
parentmedia-gfx/inkscape: Version bump (v1.0_rc1) (diff)
downloadgentoo-7673eb73a22aadefe9602b59e924f7a3bbb2887d.tar.gz
gentoo-7673eb73a22aadefe9602b59e924f7a3bbb2887d.tar.bz2
gentoo-7673eb73a22aadefe9602b59e924f7a3bbb2887d.zip
dev-python/ovs: 2.13.0 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ovs/ovs-2.13.0.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.13.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.13.0.ebuild b/dev-python/ovs/ovs-2.13.0.ebuild
new file mode 100644
index 000000000000..200bf277d486
--- /dev/null
+++ b/dev-python/ovs/ovs-2.13.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="OVS bindings for python."
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"