summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 12:54:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 12:59:36 +0200
commita57b744ff4aeaf9e06c089d7fbf82cd8eed602d5 (patch)
tree692b6cc12f3c4ff1a0a59a160255ee612a568a20 /dev-python/pandas
parentsys-apps/colorized-logs: Migrate to cmake.eclass (diff)
downloadgentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.gz
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.bz2
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.zip
Rename dev-python/{beautifulsoup → beautifulsoup4}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-1.2.3-r1.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.2.4.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.2.5.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.0.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.1.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.2.ebuild8
6 files changed, 24 insertions, 24 deletions
diff --git a/dev-python/pandas/pandas-1.2.3-r1.ebuild b/dev-python/pandas/pandas-1.2.3-r1.ebuild
index c8f0fca921c0..7fb2e473bcc8 100644
--- a/dev-python/pandas/pandas-1.2.3-r1.ebuild
+++ b/dev-python/pandas/pandas-1.2.3-r1.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -67,7 +67,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -88,7 +88,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -176,7 +176,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.2.4.ebuild b/dev-python/pandas/pandas-1.2.4.ebuild
index 74f03a0471fa..949852951883 100644
--- a/dev-python/pandas/pandas-1.2.4.ebuild
+++ b/dev-python/pandas/pandas-1.2.4.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -65,7 +65,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -86,7 +86,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -174,7 +174,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.2.5.ebuild b/dev-python/pandas/pandas-1.2.5.ebuild
index a55755019ca6..4d06d4f70ec3 100644
--- a/dev-python/pandas/pandas-1.2.5.ebuild
+++ b/dev-python/pandas/pandas-1.2.5.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -65,7 +65,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -86,7 +86,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -172,7 +172,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.0.ebuild b/dev-python/pandas/pandas-1.3.0.ebuild
index cf0c8aa8a43d..1bcde176494c 100644
--- a/dev-python/pandas/pandas-1.3.0.ebuild
+++ b/dev-python/pandas/pandas-1.3.0.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.1.ebuild b/dev-python/pandas/pandas-1.3.1.ebuild
index 922da786c996..db5cf8cfe606 100644
--- a/dev-python/pandas/pandas-1.3.1.ebuild
+++ b/dev-python/pandas/pandas-1.3.1.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.2.ebuild b/dev-python/pandas/pandas-1.3.2.ebuild
index cfd8cfcdb32f..dd278f44e3eb 100644
--- a/dev-python/pandas/pandas-1.3.2.ebuild
+++ b/dev-python/pandas/pandas-1.3.2.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib