summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-10 08:30:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-10 08:45:16 +0200
commit9bd8a54206df1dc6fd844fd0f1678f835748dc09 (patch)
tree87bba322ff36873656bc3b938218b6d89d126c05 /dev-python/paramiko
parentdev-python/jsonschema: Bump to 4.1.0 (diff)
downloadgentoo-9bd8a54206df1dc6fd844fd0f1678f835748dc09.tar.gz
gentoo-9bd8a54206df1dc6fd844fd0f1678f835748dc09.tar.bz2
gentoo-9bd8a54206df1dc6fd844fd0f1678f835748dc09.zip
dev-python/paramiko: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest1
-rw-r--r--dev-python/paramiko/files/paramiko-2.7.1-tests.patch14
-rw-r--r--dev-python/paramiko/paramiko-2.8.0.ebuild54
3 files changed, 55 insertions, 14 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index a9a727eeb4c8..5f64b23a04d3 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1 +1,2 @@
DIST paramiko-2.7.2.tar.gz 331678 BLAKE2B ff96dfd7b114255c15282f4f73e1f9425ccf77106426ccf3ad3f833b56bd5abfde867cf2d322448dc7b3777af6ab080b4e37ff8871ce17f0db17634b7f101747 SHA512 c9bc569428a0a61814cb73941356de5bae7fea7891ba4fd3f5c00ff1ee5083454bfde7e969fb4aaf5254b909f7f0132f590d67803eda8a67503e5c02ec2bf01a
+DIST paramiko-2.8.0.tar.gz 332217 BLAKE2B fcd691159b0306204064806881f8a42e7310fe23daf22c5de5ce8124d1496d48606247ab03c7657ff01560f801121a35011e0e615c5e142c41d191568f5b2300 SHA512 15f6e1cab9afdf3285804ce09b3af6c20ffc1f8e50d2549272f0ea545d1fdc858e72c7cba085db85c69aad2033655ae2f025e8ed2bd0dff574bcc03156bdb6ed
diff --git a/dev-python/paramiko/files/paramiko-2.7.1-tests.patch b/dev-python/paramiko/files/paramiko-2.7.1-tests.patch
index 5791afd044ad..a25b7c24ef27 100644
--- a/dev-python/paramiko/files/paramiko-2.7.1-tests.patch
+++ b/dev-python/paramiko/files/paramiko-2.7.1-tests.patch
@@ -27,20 +27,6 @@ index f4f84748..b1b0cdf5 100644
# pytest-xdist for test dir watching and the inv guard task
pytest-xdist==1.28.0
mock==2.0.0
-diff --git a/setup.cfg b/setup.cfg
-index 44d029c4..99159096 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -17,9 +17,6 @@ ignore = E124,E125,E128,E261,E301,E302,E303,E402,E721,W503,E203,E722
- max-line-length = 79
-
- [tool:pytest]
--# We use pytest-relaxed just for its utils at the moment, so disable it at the
--# plugin level until we adapt test organization to really use it.
--addopts = -p no:relaxed
- # Loop on failure
- looponfailroots = tests paramiko
- # Ignore some warnings we cannot easily handle.
diff --git a/tests/test_client.py b/tests/test_client.py
index 60ad310c..88fd1d53 100644
--- a/tests/test_client.py
diff --git a/dev-python/paramiko/paramiko-2.8.0.ebuild b/dev-python/paramiko/paramiko-2.8.0.ebuild
new file mode 100644
index 000000000000..85abef978302
--- /dev/null
+++ b/dev-python/paramiko/paramiko-2.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="https://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.org/project/paramiko/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="examples server"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx sites/docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.7.1-tests.patch"
+
+ if ! use server; then
+ eapply "${FILESDIR}/${PN}-2.4.2-disable-server.patch"
+ fi
+
+ eapply_user
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/*
+ fi
+}