summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 08:31:57 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 09:09:36 +0100
commit9950f78597ada968a7dc4d09f23701f4b420f532 (patch)
tree6881786bd2f56d9ef4906f38a6bfa700b4d628c7 /dev-python/parso/parso-0.5.2.ebuild
parentdev-python/hypothesis: Bump to 4.54.0 (diff)
downloadgentoo-9950f78597ada968a7dc4d09f23701f4b420f532.tar.gz
gentoo-9950f78597ada968a7dc4d09f23701f4b420f532.tar.bz2
gentoo-9950f78597ada968a7dc4d09f23701f4b420f532.zip
dev-python/parso: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso/parso-0.5.2.ebuild')
-rw-r--r--dev-python/parso/parso-0.5.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/parso/parso-0.5.2.ebuild b/dev-python/parso/parso-0.5.2.ebuild
new file mode 100644
index 000000000000..f5c44e291ec2
--- /dev/null
+++ b/dev-python/parso/parso-0.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest