summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 22:39:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:33 -0500
commit515d0b147c980c9304aa80e0fd6cfc83e003df2b (patch)
treee42b1b4d0d8d86a4d91f8361fbd66c11641043a0 /dev-python/partd
parentdev-python/toolz: add py37 support to 0.9.0 (diff)
downloadgentoo-515d0b147c980c9304aa80e0fd6cfc83e003df2b.tar.gz
gentoo-515d0b147c980c9304aa80e0fd6cfc83e003df2b.tar.bz2
gentoo-515d0b147c980c9304aa80e0fd6cfc83e003df2b.zip
dev-python/partd: add py37 support to 0.3.8
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/partd')
-rw-r--r--dev-python/partd/partd-0.3.8.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-python/partd/partd-0.3.8.ebuild b/dev-python/partd/partd-0.3.8.ebuild
index 6542114fed31..24bd833ad685 100644
--- a/dev-python/partd/partd-0.3.8.ebuild
+++ b/dev-python/partd/partd-0.3.8.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
@@ -20,12 +19,12 @@ RDEPEND="dev-python/locket[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/blosc[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/blosc[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
)"
python_test() {