summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 22:39:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-10 00:16:28 +0200
commitac83e071bb0d29da7c5da46ace920ea66e6b1ea4 (patch)
tree741d8e819f39fb8b10768dc63db9c29110750eb0 /dev-python/paste
parentdev-python/hypothesis: Bump to 5.33.2 (diff)
downloadgentoo-ac83e071bb0d29da7c5da46ace920ea66e6b1ea4.tar.gz
gentoo-ac83e071bb0d29da7c5da46ace920ea66e6b1ea4.tar.bz2
gentoo-ac83e071bb0d29da7c5da46ace920ea66e6b1ea4.zip
dev-python/paste: Bump to 3.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.4.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 7f91de2f3c9d..debd229bd226 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,2 +1,3 @@
DIST Paste-3.4.1.tar.gz 633491 BLAKE2B be599b9385ecad754fc431a936ccd78ee088825c88040986ddd4ccb3ca81342d642a23699ca7ef9338be5360703ce5d5a2d966ff9e405744b286fa3fe69bce41 SHA512 90b6bd33e83fde70691be6206ad1de653603900b88fade79f6960df22bb84c6e82c9b6f4ddc11406f4e206273a2b5591b81ca034f8f42a3e993b85b16d07e3f0
DIST Paste-3.4.3.tar.gz 630569 BLAKE2B fa81b60ad048a2c999d4e57992f5a5603680bf7505f13a8618a55425b388ef906ceb2e118821d689905a20e7ec2b31d27a6aecd704f529540db6c4436f30268c SHA512 0869a3330a74cc14f88fb5ce24183328ec38fed1fc5cd669b428f09ee2fcafc770e95c2f4dc8de86dfce4d66861bad26c9502cccb81966c519ca4593ada094b1
+DIST Paste-3.4.4.tar.gz 630575 BLAKE2B 1d81efae1e1a783daf2d3fa86eb2e80cb95173a4bb182326c27471e2612b7de047bb3d98c0943aba9600f9888d760f39edd7c93ff4c16fbd4c90f68ebaa0caf6 SHA512 f977fa02b6800be27f703115b87987dcf8a1e4edd681f253b20fb363bfe625109b424ec6a0faba066e1d074f55a2ba336e17654f899b3100c9e3c3252d38b5a6
diff --git a/dev-python/paste/paste-3.4.4.ebuild b/dev-python/paste/paste-3.4.4.ebuild
new file mode 100644
index 000000000000..5bbbe51a411a
--- /dev/null
+++ b/dev-python/paste/paste-3.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # TODO: 'Address already in use'
+ sed -e 's:test_address_family_v4:_&:' \
+ -i tests/test_httpserver.py || die
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}