summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-14 13:36:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-14 14:01:14 +0200
commitb6e2d1adf76a11c5239826e552d0f876c592a2f8 (patch)
tree3e7288b422f647e6e106575884353ef0b5fed749 /dev-python/paste
parentdev-python/jupyter_client: Bump to 6.1.6 (diff)
downloadgentoo-b6e2d1adf76a11c5239826e552d0f876c592a2f8.tar.gz
gentoo-b6e2d1adf76a11c5239826e552d0f876c592a2f8.tar.bz2
gentoo-b6e2d1adf76a11c5239826e552d0f876c592a2f8.zip
dev-python/paste: Bump to 3.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.4.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 0443365ee403..3b214d212ded 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.4.1.tar.gz 633491 BLAKE2B be599b9385ecad754fc431a936ccd78ee088825c88040986ddd4ccb3ca81342d642a23699ca7ef9338be5360703ce5d5a2d966ff9e405744b286fa3fe69bce41 SHA512 90b6bd33e83fde70691be6206ad1de653603900b88fade79f6960df22bb84c6e82c9b6f4ddc11406f4e206273a2b5591b81ca034f8f42a3e993b85b16d07e3f0
+DIST Paste-3.4.2.tar.gz 630511 BLAKE2B b03e5bcf8bcac1898de49f829f788215979e5f59453f2c3ad8bcea068f1b1c9d73ffe74c5acc0227e9b71afc3b316624342bfbe1000908193e85d0b43a52d34a SHA512 fe4b1582f58c0033c95740b5ac380a93e5f67b6ef1e5d57e943270228650bce1772c4f01357f8367b3fefde3892f316955c22c8266679190b7de0a560c663d14
diff --git a/dev-python/paste/paste-3.4.2.ebuild b/dev-python/paste/paste-3.4.2.ebuild
new file mode 100644
index 000000000000..a86c3a7bb14d
--- /dev/null
+++ b/dev-python/paste/paste-3.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # TODO: 'Address already in use'
+ sed -e 's:test_address_family_v4:_&:' \
+ -i tests/test_httpserver.py || die
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}