summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-27 11:53:36 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-27 13:19:26 -0800
commitca94f38b2843bca231462c6db5afb25edd3de59c (patch)
tree1fe99e982b22fe1f1c9775867e78310e159a7809 /dev-python/paste
parentdev-python/namespace-paste-1-r1: Add py38, pypy{,3} (diff)
downloadgentoo-ca94f38b2843bca231462c6db5afb25edd3de59c.tar.gz
gentoo-ca94f38b2843bca231462c6db5afb25edd3de59c.tar.bz2
gentoo-ca94f38b2843bca231462c6db5afb25edd3de59c.zip
dev-python/paste-3.2.3: Bump, add py38 and pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.2.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 6d88e672f4f1..17034e98a94b 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,2 +1,3 @@
DIST Paste-2.0.3.tar.gz 643935 BLAKE2B 140f88cbab40728713a052e5aca0c7f14336d526a2c7bcd6a279fcdd13b14ed83938f69997182b43d2a83a76f51586c3b9132428f0f9c9e9ba08b6ff820827b9 SHA512 174b06d77bc6e1d4079e8de7df40412ffda098364efd4e3f915f858be1188c8a6fb546fe4ab981ccc067ec77b7171083b2469e7db6fc3b777d5a24151c928362
DIST Paste-3.0.7.tar.gz 628999 BLAKE2B c91bb228fc2c36da1e7d487d521b9f57df19f4cb76731ec8ac17786aae087fe820760d19798a8da0ab6ce50f24b8a1fcb9d5189e6c48cffbda75ddfc9cf9f617 SHA512 adf823d208065b00a4bf1473e7550a1e0907d1da88000e87ea3a5dfb36f22c2bb33dda21ccf096da1512a0f2db2ad540a66efe751bbab8bfb49cd4ad456d5460
+DIST Paste-3.2.3.tar.gz 628900 BLAKE2B 3f6bc741a716f33b82fa3bf8e1ab6ba3c17a56ebf3f90ccce0c1a925f982a2a0b460f433e15045321bb4b7c22c6fe9238cf6c7c76b78dc86d414729b67f0791e SHA512 8775a4c6b1863355a2acb3b88258e342db768942ccf28edc8654d7a1a15c5a036f4f8c5c9d917d51e74c9260170234f9c499cefd709b0fbd39ffd4d1b7afcb79
diff --git a/dev-python/paste/paste-3.2.3.ebuild b/dev-python/paste/paste-3.2.3.ebuild
new file mode 100644
index 000000000000..49cad2fc0957
--- /dev/null
+++ b/dev-python/paste/paste-3.2.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="Paste"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="flup openid"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ flup? ( dev-python/flup[$(python_gen_usedep 'python2*')] )
+ openid? ( dev-python/python-openid[$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Disable failing tests.
+ rm -f tests/test_cgiapp.py || die
+ sed \
+ -e "s/test_find_file/_&/" \
+ -e "s/test_deep/_&/" \
+ -e "s/test_static_parser/_&/" \
+ -i tests/test_urlparser.py || die "sed failed"
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ # remove unnecessary dep
+ sed -i "s:'pytest-runner'::" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+#python_compile() {
+# distutils-r1_python_compile egg_info --egg-base "${BUILD_DIR}/lib"
+#}
+
+#python_compile_all() {
+# use doc && esetup.py build_sphinx
+#}
+
+#python_install() {
+# distutils-r1_python_install egg_info --egg-base "${BUILD_DIR}/lib"
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}