summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:45:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:45:15 +0200
commitd9e6c49bc75478c3f1c062e18cbb96724aadbba4 (patch)
tree1f932cd157af4741e561d231206dd46f07a00dd9 /dev-python/paste
parentdev-python/passlib: Port to py39 (diff)
downloadgentoo-d9e6c49bc75478c3f1c062e18cbb96724aadbba4.tar.gz
gentoo-d9e6c49bc75478c3f1c062e18cbb96724aadbba4.tar.bz2
gentoo-d9e6c49bc75478c3f1c062e18cbb96724aadbba4.zip
dev-python/paste: Bump to 3.4.0, py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.4.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 36e9389824bb..a0d69ae13f70 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.2.3.tar.gz 628900 BLAKE2B 3f6bc741a716f33b82fa3bf8e1ab6ba3c17a56ebf3f90ccce0c1a925f982a2a0b460f433e15045321bb4b7c22c6fe9238cf6c7c76b78dc86d414729b67f0791e SHA512 8775a4c6b1863355a2acb3b88258e342db768942ccf28edc8654d7a1a15c5a036f4f8c5c9d917d51e74c9260170234f9c499cefd709b0fbd39ffd4d1b7afcb79
+DIST Paste-3.4.0.tar.gz 630425 BLAKE2B a361450597e8dce1d9cb99ce2a723cb8feb08909975662e1fbe8b353c20900ac5d994e8373ea4db42776aee1901f51363f8338ba4e3c35462f3c3917161a02ef SHA512 fbe0d1f39d8147846b3a30f18e6776c31eb5bcd8f461c0bf7afc35533c65c2ddf74263807be1b73b76c49cd6cc73c210a37ca651ef1f34e727ccf0687478085a
diff --git a/dev-python/paste/paste-3.4.0.ebuild b/dev-python/paste/paste-3.4.0.ebuild
new file mode 100644
index 000000000000..a86c3a7bb14d
--- /dev/null
+++ b/dev-python/paste/paste-3.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # TODO: 'Address already in use'
+ sed -e 's:test_address_family_v4:_&:' \
+ -i tests/test_httpserver.py || die
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}