summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-10-24 23:28:13 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-10-29 00:42:27 +0000
commit97c641403195f9900e208a71cecc822afd1c2f37 (patch)
tree4a993634766a7a419c7fd0ecc1f0c74e78bd5efe /dev-python/patch/patch-1.16.ebuild
parentwww-apache/mod_perl: Version bump to actual release (diff)
downloadgentoo-97c641403195f9900e208a71cecc822afd1c2f37.tar.gz
gentoo-97c641403195f9900e208a71cecc822afd1c2f37.tar.bz2
gentoo-97c641403195f9900e208a71cecc822afd1c2f37.zip
dev-python/patch: initial import
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/patch/patch-1.16.ebuild')
-rw-r--r--dev-python/patch/patch-1.16.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/patch/patch-1.16.ebuild b/dev-python/patch/patch-1.16.ebuild
new file mode 100644
index 000000000000..7c917ccb3188
--- /dev/null
+++ b/dev-python/patch/patch-1.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit python-r1
+
+DESCRIPTION="Library to parse and apply unified diffs"
+HOMEPAGE="https://github.com/techtonik/python-patch/"
+SRC_URI="https://github.com/techtonik/python-patch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/python-${P}"
+
+src_test() {
+ python_foreach_impl tests/run_tests.py
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doexe patch.py
+}