summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-10-03 14:40:51 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-10-03 14:40:51 -0500
commit19a8a90f56091d8b9ca0527c0a5c3a4a4063d545 (patch)
tree48a329383215fe7a243b6be853c26f14b789f5d7 /dev-python/pbr
parentsci-libs/libsigrokdecode: Version bump (diff)
downloadgentoo-19a8a90f56091d8b9ca0527c0a5c3a4a4063d545.tar.gz
gentoo-19a8a90f56091d8b9ca0527c0a5c3a4a4063d545.tar.bz2
gentoo-19a8a90f56091d8b9ca0527c0a5c3a4a4063d545.zip
dev-python/pbr: 4.3.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-4.3.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 5e26a82aea92..246b483e66d9 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -3,3 +3,4 @@ DIST pbr-1.10.0.tar.gz 111425 BLAKE2B 2cef589ada2892dd8357ad3248c4b544d58c699d24
DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116320abd4552bb67886498d89eced1f95e1efdd6ac0511a5587eb479dc9d2963a74e92300463c3c53201e7d SHA512 c01fb83678f8fc3acddc153dd341a17ed9d602b6770f0ff244b1c5b54c37d4ddcbd0c3d726f7d7020865819e02797c1c79a0c15e9ee2ae5c1510fce7112b2a3a
DIST pbr-4.1.1.tar.gz 108683 BLAKE2B 5c0157ff14590113e7baae0bdca1ff46108a7a10d6eae8bd0a2d06bee62b4aa65eed25c900ae1b67324ac6b416641081c63a274c9694db1877b5d9073c1c04d9 SHA512 ed739901b3a2d1eafa1d4d408a39f1e5d967776571efe0913877145aaccee3114558e107a4e5704403288324c63a08cfbca07a3409bd1baafcbc33105abdf3e4
DIST pbr-4.2.0.tar.gz 107958 BLAKE2B 716283ceb7b1a8da41e77441c7526bf8cbdb5be7c710013630d3bbddf7de0ce37f3abd063f6103f3ec27fc5c09796f6452d8117df3b533b3c7377bf6dce7d37f SHA512 d46d93333b4d0d3fd5c14e0a474ca7beceddf794a5dbcf66f810993b8d33b48602518072effcd429566f4eede2a38c4aec289df262c2c0e7ab4b82474e14f14d
+DIST pbr-4.3.0.tar.gz 112935 BLAKE2B 460d9f93d66a9381360f3b47beb0fb8a3ffcc21be231e5875019b00d5b60efacd7237c073f9d7850b23aed75ad842fbb6b082d665367dcc5a059b8eb0064641d SHA512 6e87c62ca434a85506f1e9d9e92d29ccccd24484120748fdfae081e3a574a9d9edcd2e3960bd0ecb5d3c8543a919b8b0f829662957ed657693022c8940f76d74
diff --git a/dev-python/pbr/pbr-4.3.0.ebuild b/dev-python/pbr/pbr-4.3.0.ebuild
new file mode 100644
index 000000000000..5011d435355b
--- /dev/null
+++ b/dev-python/pbr/pbr-4.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0[$(python_gen_usedep python{2_7,3_4,3_5,3_6})]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+ einfo "rogue tests disabled"
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ stestr init || die "stestr init failed under ${EPYTHON}"
+ stestr run || die "stestr run failed under ${EPYTHON}"
+}