summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-16 10:33:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-16 10:33:53 -0500
commit619fb00272dfacf40580cd76c866757a1b9c33f5 (patch)
tree0db6594d226b614323a06f9e33db421eecd176c2 /dev-python/pbr
parentdev-cpp/tbb: arm stable wrt bug #713244 (diff)
downloadgentoo-619fb00272dfacf40580cd76c866757a1b9c33f5.tar.gz
gentoo-619fb00272dfacf40580cd76c866757a1b9c33f5.tar.bz2
gentoo-619fb00272dfacf40580cd76c866757a1b9c33f5.zip
dev-python/pbr: fix pbr with new wheel
Closes: https://bugs.gentoo.org/582602 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-4.2.0-r3.ebuild (renamed from dev-python/pbr/pbr-4.2.0-r2.ebuild)5
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 18ab44f91828..585bf23c8a1d 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -2,3 +2,4 @@ DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116
DIST pbr-4.1.1.tar.gz 108683 BLAKE2B 5c0157ff14590113e7baae0bdca1ff46108a7a10d6eae8bd0a2d06bee62b4aa65eed25c900ae1b67324ac6b416641081c63a274c9694db1877b5d9073c1c04d9 SHA512 ed739901b3a2d1eafa1d4d408a39f1e5d967776571efe0913877145aaccee3114558e107a4e5704403288324c63a08cfbca07a3409bd1baafcbc33105abdf3e4
DIST pbr-4.2.0.tar.gz 107958 BLAKE2B 716283ceb7b1a8da41e77441c7526bf8cbdb5be7c710013630d3bbddf7de0ce37f3abd063f6103f3ec27fc5c09796f6452d8117df3b533b3c7377bf6dce7d37f SHA512 d46d93333b4d0d3fd5c14e0a474ca7beceddf794a5dbcf66f810993b8d33b48602518072effcd429566f4eede2a38c4aec289df262c2c0e7ab4b82474e14f14d
DIST pbr-5.1.1.tar.gz 113476 BLAKE2B 9e4857f13eba2e18abffa3d7c56f05eb5a5997b855f02770a807cec110e6eb4596b333b67beba2a507bb8cb55fcd3ed87a012b4a3a245b81d0a74737c010f157 SHA512 cd6f8bdc6db80841e948dbb278423556861aa681b970050a40c920dd00e32704a29cfdd28aabd4d14e0e577fff1bc816f0646a62c9450d0d85233ab5802606f1
+DIST pbr-wheel.patch 2781 BLAKE2B f36ac5bfe22e97dd93735581461f5ac79753543e0e03bcf569d95a3bfac70362c50af8bfc745e5d29ff07092e9669782ddaf3f8edd70501966c4d4682a5bfa33 SHA512 3c89eb9ea617da1d3e2eca3fadff6f5be9f55e4a258e1fbcdd221f3c0ec3cbfd13abe401bdfdb4b464baf74b8111e981f2dab4fb2839a4b52aee65212d1589f5
diff --git a/dev-python/pbr/pbr-4.2.0-r2.ebuild b/dev-python/pbr/pbr-4.2.0-r3.ebuild
index 50b10709d005..3b838aa43596 100644
--- a/dev-python/pbr/pbr-4.2.0-r2.ebuild
+++ b/dev-python/pbr/pbr-4.2.0-r3.ebuild
@@ -10,7 +10,8 @@ inherit distutils-r1
DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
HOMEPAGE="https://github.com/openstack-dev/pbr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/openstack/pbr/commit/f14a3b2b73c6c95edbea8de799cf1df07decdf0e.patch -> ${PN}-wheel.patch"
LICENSE="Apache-2.0"
SLOT="0"
@@ -46,6 +47,8 @@ DEPEND="
)"
PDEPEND=""
+PATCHES=("${DISTDIR}/${PN}-wheel.patch")
+
# This normally actually belongs here.
python_prepare_all() {
# This test passes when run within the source and doesn't represent a failure, but rather