summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2021-01-28 12:26:07 -0800
committerSteve Arnold <nerdboy@gentoo.org>2021-01-28 12:26:56 -0800
commitc63c04acdcde27458756eda64bc32646b7bf9e65 (patch)
treeb0b3e4e602cc7601b11fc3ae87459994ad55b0d4 /dev-python/pdfrw
parentdev-ml/timezone: Keyword 0.14.0 x86, #766884 (diff)
downloadgentoo-c63c04acdcde27458756eda64bc32646b7bf9e65.tar.gz
gentoo-c63c04acdcde27458756eda64bc32646b7bf9e65.tar.bz2
gentoo-c63c04acdcde27458756eda64bc32646b7bf9e65.zip
dev-python/pdfrw: add upstream cleanup patch release
* not including removal bug closure here pending feedback Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'dev-python/pdfrw')
-rw-r--r--dev-python/pdfrw/Manifest2
-rw-r--r--dev-python/pdfrw/metadata.xml2
-rw-r--r--dev-python/pdfrw/pdfrw-0.4.ebuild53
-rw-r--r--dev-python/pdfrw/pdfrw-0.4_p1.ebuild58
4 files changed, 60 insertions, 55 deletions
diff --git a/dev-python/pdfrw/Manifest b/dev-python/pdfrw/Manifest
index b435bb703dcb..17ba1dd8c366 100644
--- a/dev-python/pdfrw/Manifest
+++ b/dev-python/pdfrw/Manifest
@@ -1,2 +1,2 @@
-DIST pdfrw-0.4.tar.gz 95402 BLAKE2B 00f01f8d4cca9c5306d08094639d4cb10c53aca1c81b6c65f5639c8862a067e562c164523cc58abddb06b39dabcc50c2fbcdcf04a291309cac709cbfd0cf4673 SHA512 6c0b629e837f9bd479a288bcd040952b98920da345113bf90167becbdf2f90a9d6c082c5e7988c68118bd62a2a5a0d22f98523407996531bb5d3031e847e10b0
+DIST pdfrw-0.4-1.tar.gz 143615 BLAKE2B 281dc94c762dcc776e2c9c84609b59ca32387510bcfbec39271a6073533f9ad5d416cf4250b3dcd8564973d197ce090719c5561f58b972c89d463b90723ac8e6 SHA512 f2ef6a966cb1b947425679e6c16e658b5d1dbc13d62fb2e1edc278508b03f6c6847b3c83dab8bcd7df3438e587df066bc16b653461ae402bb8688ddb05f4e886
DIST pdfrw-static_pdfs-d646009a0e3e71daf13a52ab1029e2230920ebf4.tar.gz 25243391 BLAKE2B 5c491d56c9731352907787bbe10b8b3ac362f0c7892ddcd15a1299d3b2b4bb604662f6231aa22478290992a345e769af2e2c2459a25a16c370ea05fa68101f80 SHA512 9bf1d5ddc8f55b40b50041e745579406bb0036fb7795ac40064aad7cdf592869051ba84a5ab080042e237690bb2f1811b86b2a4424535aa4c367f6e29a0c34eb
diff --git a/dev-python/pdfrw/metadata.xml b/dev-python/pdfrw/metadata.xml
index d95f88bab1f6..fe2a825dbce0 100644
--- a/dev-python/pdfrw/metadata.xml
+++ b/dev-python/pdfrw/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">pdfrw</remote-id>
- <remote-id type="github">pmaupin/pdfrw</remote-id>
+ <remote-id type="github">sarnold/pdfrw</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pdfrw/pdfrw-0.4.ebuild b/dev-python/pdfrw/pdfrw-0.4.ebuild
deleted file mode 100644
index 9a00f180cbc5..000000000000
--- a/dev-python/pdfrw/pdfrw-0.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-PDFS_COMMIT=d646009a0e3e71daf13a52ab1029e2230920ebf4
-DESCRIPTION="PDF file reader/writer library"
-HOMEPAGE="https://github.com/pmaupin/pdfrw"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- test? (
- https://github.com/pmaupin/static_pdfs/archive/${PDFS_COMMIT}.tar.gz
- -> pdfrw-static_pdfs-${PDFS_COMMIT}.tar.gz
- )"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86"
-
-BDEPEND="
- test? ( dev-python/reportlab[${PYTHON_USEDEP}] )"
-
-# unittest would be sufficient but its output is unreadable
-distutils_enable_tests pytest
-
-src_unpack() {
- default
- if use test; then
- mv "static_pdfs-${PDFS_COMMIT}"/* "${P}"/tests/static_pdfs/ || die
- fi
-}
-
-src_prepare() {
- # broken upstream (sensitive to reportlab version?)
- sed -e 's:test_rl1_platypus:_&:' \
- -i tests/test_examples.py || die
- # fails with py3
- sed -e '/repaginate\/7037/s:[0-9a-f]*$:skip:' \
- -e '/.*\/72eb/s:[0-9a-f]*$:skip:' \
- -i tests/expected.txt || die
- # fix py3.7+ some
- sed -i -e 's:raise StopIteration:return:' pdfrw/tokens.py || die
-
- distutils-r1_src_prepare
-}
-
-src_test() {
- cd tests || die
- distutils-r1_src_test
-}
diff --git a/dev-python/pdfrw/pdfrw-0.4_p1.ebuild b/dev-python/pdfrw/pdfrw-0.4_p1.ebuild
new file mode 100644
index 000000000000..00a4ad7b5a1c
--- /dev/null
+++ b/dev-python/pdfrw/pdfrw-0.4_p1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+PDFS_COMMIT=d646009a0e3e71daf13a52ab1029e2230920ebf4
+DESCRIPTION="PDF file reader/writer library"
+HOMEPAGE="https://github.com/pmaupin/pdfrw"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/hexdump.git"
+ EGIT_BRANCH="main"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV="${PV/_p/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz
+ test? ( https://github.com/pmaupin/static_pdfs/archive/${PDFS_COMMIT}.tar.gz
+ -> pdfrw-static_pdfs-${PDFS_COMMIT}.tar.gz )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="crypt test"
+
+BDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
+ crypt? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )
+ test? ( dev-python/reportlab[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+# unittest would be sufficient but its output is unreadable
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "static_pdfs-${PDFS_COMMIT}"/* "${MY_P}"/tests/static_pdfs || die
+ fi
+}
+
+src_prepare() {
+ # broken upstream (sensitive to reportlab version?)
+ #sed -e 's:test_rl1_platypus:_&:' \
+ # -i tests/test_examples.py || die
+ eapply "${FILESDIR}/pdfrw-fix-import-collections-warning.patch"
+ use test && eapply "${FILESDIR}/pdfrw-static-fix-import-collections-warning.patch"
+
+ distutils-r1_src_prepare
+}