summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-02-25 15:09:37 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-25 16:43:02 -0800
commit59f4c38e1c9dc23a4465f8635c52568d3981a9b0 (patch)
treefd9aad3d38176826cdb36458380d353918a15241 /dev-python/pecan
parentdev-python/logutils-0.3.5: Add py39 (diff)
downloadgentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.tar.gz
gentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.tar.bz2
gentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.zip
dev-python/pecan-1.4.0: Version bump, add py39
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index f59c08506a10..61458879f1d2 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1 +1,2 @@
DIST pecan-1.3.3.tar.gz 120595 BLAKE2B d1169b6af4fe822259a6bad75068475324cd9c7811a8e62ae6f9c2b9bbfe69b7688a03de9c4a1a4b27666f22c34fdac95ebddbb50feba6ccda60fd2a7f190d38 SHA512 ffa171d4847e549f959dd5ed71f32b3d689ef7e2548302adfadd007f5217c4e1a16088612c27005ac6ae38bb5a99aa532e84be71ae4abf6b06dfdb26ff5cac89
+DIST pecan-1.4.0.tar.gz 124233 BLAKE2B 42ac41d9e4aba2ad40b89d2ec742ae82a3d9f599c79d0ac5cce199b8ee50ba5e0765f02dc8812defd3e7276176d0e4dadf06b56256e9808771805df64811e9d4 SHA512 102ac8549fcb8c1f29aaf6facf1fba3dd06c454ed6262c3b0e9a009063033defbf0011b4117d854da1f4770368d3dbce1e3930daabfb0c7ee069eb2522bac7e1
diff --git a/dev-python/pecan/pecan-1.4.0.ebuild b/dev-python/pecan/pecan-1.4.0.ebuild
new file mode 100644
index 000000000000..0582e6a2ec9b
--- /dev/null
+++ b/dev-python/pecan/pecan-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest