summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 13:02:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:43:38 -0500
commitc28f1de8fde2faa5cac9d59b9632028f8ff23c7b (patch)
tree46d67003d5e2b1d2e2e093f722c820cc2e177a9b /dev-python/pecan
parentnet-wireless/iwd: add upstream patch for bug 683198 (diff)
downloadgentoo-c28f1de8fde2faa5cac9d59b9632028f8ff23c7b.tar.gz
gentoo-c28f1de8fde2faa5cac9d59b9632028f8ff23c7b.tar.bz2
gentoo-c28f1de8fde2faa5cac9d59b9632028f8ff23c7b.zip
dev-python/pecan: 1.3.3 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.3.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index a55228fd175b..e6965649a0ab 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1,3 +1,4 @@
DIST pecan-1.0.4.tar.gz 119575 BLAKE2B eead6234fe26f4698c03f965aba6cd1078369693827574ca3b0b39da4bf8b0b660c01a2e57b3789c092df1cf3f1529ae5d74385055def47482a7f95df5283976 SHA512 cbd5bc21658e68553baa55b74f82f7198ba261bf48d2889732ebbdbcb7f00d0a68f85dcaf946e7349000e78217c532d2017606316335211abd1fac15b947ed7f
DIST pecan-1.1.2.tar.gz 120316 BLAKE2B aa63103552e8563d7da27d2ee06706f5dbe507557cf8d76c8f196345f453efb02a13c0e1eccfb5e2db7fab850c4fc22b934da0ddfaf92b048edc729517621197 SHA512 672771fb8645bd11f6d89e7be46b6a85ea640b1951cc286cfedc7813f4f076e8435474adcf88d5c149b4d3933fea9c458b155df8b0ce491dac54bad46e4186be
DIST pecan-1.2.1.tar.gz 120364 BLAKE2B aa0f75249a3c91dbe45376180f1886ec6ff4169c407166dc7a6014152a4cc50bfb8085fcb53996fad75f3b142784ad0a6c2c52c7eb92ca1585dae9c771116c2d SHA512 ce7007f2ea9cf01b7375919c1624b8bf9b8a836d383b6a1906b6d33190b6586ae8700149d862a6a9f16d7eb5e29d055540a13122f67bd3074270e3791a82a233
+DIST pecan-1.3.3.tar.gz 120595 BLAKE2B d1169b6af4fe822259a6bad75068475324cd9c7811a8e62ae6f9c2b9bbfe69b7688a03de9c4a1a4b27666f22c34fdac95ebddbb50feba6ccda60fd2a7f190d38 SHA512 ffa171d4847e549f959dd5ed71f32b3d689ef7e2548302adfadd007f5217c4e1a16088612c27005ac6ae38bb5a99aa532e84be71ae4abf6b06dfdb26ff5cac89
diff --git a/dev-python/pecan/pecan-1.3.3.ebuild b/dev-python/pecan/pecan-1.3.3.ebuild
new file mode 100644
index 000000000000..6abcc6f2fe08
--- /dev/null
+++ b/dev-python/pecan/pecan-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"