summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-22 22:19:12 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-22 22:21:10 +0800
commit27fb9d59113ca61af75cc6a2200983af5e663b05 (patch)
tree30ac6532c180d5a76ac0751218a7af21e73901cc /dev-python/pgmagick
parentMerge remote-tracking branch 'remotes/hydrapolic/filebeat' (diff)
downloadgentoo-27fb9d59113ca61af75cc6a2200983af5e663b05.tar.gz
gentoo-27fb9d59113ca61af75cc6a2200983af5e663b05.tar.bz2
gentoo-27fb9d59113ca61af75cc6a2200983af5e663b05.zip
dev-python/pgmagick: bump to vn. 0.6, added py3.4 py3.5 support
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/pgmagick')
-rw-r--r--dev-python/pgmagick/Manifest1
-rw-r--r--dev-python/pgmagick/pgmagick-0.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pgmagick/Manifest b/dev-python/pgmagick/Manifest
index 8a900c28dbdd..4d216e80b465 100644
--- a/dev-python/pgmagick/Manifest
+++ b/dev-python/pgmagick/Manifest
@@ -1,2 +1,3 @@
DIST pgmagick-0.5.10.tar.gz 39826 SHA256 89274107200a84e56e0fc4f6c482fd3b865d28c820c6d3e81cdbd4089e2dd233 SHA512 a5b05c50e8ffd61dc84547d7dcba7d47b4d31d19b00c372eac84324faa9b88194ef3283224a60ce0bc17fa1de8f22cec188dc03388fb119ace7c4b6c6eab875f WHIRLPOOL aeaee541af0ebc6f474fc20a5b38d635cd27602594602d7132ab96cc11172509fa5218e71719a46792a7dfe63872a30ef11019c92eb0d0bb433a468de59b7494
DIST pgmagick-0.5.11.tar.gz 39872 SHA256 83d611bb516eb2465a0167463f427f3fbdd6fa4efa1b8a24caa64fcec6bc8b3d SHA512 6b53204319538ca05e25e601135c47acfffb8af7f062c567875ad5740daf0d30263aefe7180a478d605b98922a7f3e5a2ae1f56d01b2e5f1d5c6b4b34fb6d44f WHIRLPOOL f53bacd57521bddea70564fbe934de918dc1563859656804c4d1d5e941e9c23869c4636b047ceab6baff726b83040a45849f5e4eabdb805198aa5bc694021358
+DIST pgmagick-0.6.tar.gz 40593 SHA256 9e315c17edcc10adeae05aac49b6082a5aca8937822d207563858875c814186b SHA512 b6c80ebfe0361e0a1b54a9cb8fc8102db0aa56347f4c8842cd8745f6beab1b01e1f51b1084fb51718db4b96b560aa220e103395d42d300017a17a9adf52bd294 WHIRLPOOL d3d19bbf62b40a1f05cdd5404af456a3de988b361b8e160ec272c93bc118b3d45cf348c1bda86fbfc0087d3bc1dc099db978e87bdea1a916af5fd3292439c973
diff --git a/dev-python/pgmagick/pgmagick-0.6.ebuild b/dev-python/pgmagick/pgmagick-0.6.ebuild
new file mode 100644
index 000000000000..f9c6f4f09207
--- /dev/null
+++ b/dev-python/pgmagick/pgmagick-0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another boost.python based wrapper for GraphicsMagick"
+HOMEPAGE="https://pypi.python.org/pypi/pgmagick/ https://bitbucket.org/hhatto/pgmagick/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/graphicsmagick[cxx]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ media-fonts/corefonts )"
+
+python_test() {
+ # The tests are written for py2 only, however there is only
+ # one test, test_pgmagick_libinfo.py
+ # Need to adjust the one test to py3 syntax
+ if python_is_python3; then
+ sed -e 's: libinfo.version:(libinfo.version):' \
+ -e 's: libinfo.library:(libinfo.library):' \
+ -i test/test_pgmagick_libinfo.py || die
+ fi
+
+ for test in test/test_*.py; do
+ "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
+ done
+ # As long as the order of pythons are not agon changed, this will suffice
+}