summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2017-11-12 14:31:16 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-12 20:22:06 +0100
commit592f68ce76daf89e6ea445b9c3f4303a5c722a73 (patch)
tree4f927cb133c39c203c2063f2636eb453099305ca /dev-python/pilkit
parentprofiles/arch/arm: drop python3_5 from use.stable.mask (diff)
downloadgentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.tar.gz
gentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.tar.bz2
gentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.zip
dev-python/pilkit: new package
Add new package dev-python/pilkit to the tree. Closes: https://bugs.gentoo.org/637230 Thanks-to: Thomas Deutschmann whissi@gentoo.org Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-python/pilkit')
-rw-r--r--dev-python/pilkit/Manifest1
-rw-r--r--dev-python/pilkit/metadata.xml23
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild28
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pilkit/Manifest b/dev-python/pilkit/Manifest
new file mode 100644
index 000000000000..84f831f35ae3
--- /dev/null
+++ b/dev-python/pilkit/Manifest
@@ -0,0 +1 @@
+DIST pilkit-2.0.tar.gz 160077 SHA256 01a1c3b920f4a0f73d4f0ddd252031eba78697c7af8ba5f94e43c8b2fc7a07cf SHA512 7732c67bc00db53c6849c907233381cca7f9055d55d479958a7b97db277524ac280753fd40c0023fe2b34f98b7261134f993585e658275ccd4c67f357c13de51 WHIRLPOOL a99362e2bbdab5c96e8d39a367f98a9cd7947cca18e68a3b903f2a5cc9b5279fdf4fd1f489073e594823def31e4e2dc02c256e4834a7bc4e889550a9cc978f8c
diff --git a/dev-python/pilkit/metadata.xml b/dev-python/pilkit/metadata.xml
new file mode 100644
index 000000000000..b4d5770a92d6
--- /dev/null
+++ b/dev-python/pilkit/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thomas@gstaedtner.net</email>
+ <name>Thomas Gstädtner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pilkit</remote-id>
+ <remote-id type="github">matthewwithanm/pilkit</remote-id>
+ <bugs-to>
+ https://github.com/matthewwithanm/pilkit/issues
+ </bugs-to>
+ </upstream>
+ <longdescription>
+ PILKit is a collection of utilities for working with
+ PIL (the Python Imaging Library).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
new file mode 100644
index 000000000000..b55d51a92e54
--- /dev/null
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities and processors for the Python Imaging Libary"
+HOMEPAGE="https://github.com/matthewwithanm/pilkit"
+SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests --verbose || die
+}